Highlighted

AIR Beta 21.0.0.123 SDK Issues

Explorer ,
Feb 01, 2016

Copy link to clipboard

Copied

Hi,

After I have updated the SDK (overlaid on Apache Flex 4.15 final), I'm getting the following errors on all my workers (I have 4 in total), and they fail to start up.

VerifyError: Error #1053: Illegal override of softKeyboardType in spark.components.supportClasses.SkinnableTextBase.


I have searched my entire workspace and there are no hits for "softKeyboardType" on my own code.

The project compiles and works as expected when using AIR 20.0.0.225.

Any advice?

Best regards,

Leo

TOPICS
Air beta

Views

608

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AIR Beta 21.0.0.123 SDK Issues

Explorer ,
Feb 01, 2016

Copy link to clipboard

Copied

Hi,

After I have updated the SDK (overlaid on Apache Flex 4.15 final), I'm getting the following errors on all my workers (I have 4 in total), and they fail to start up.

VerifyError: Error #1053: Illegal override of softKeyboardType in spark.components.supportClasses.SkinnableTextBase.


I have searched my entire workspace and there are no hits for "softKeyboardType" on my own code.

The project compiles and works as expected when using AIR 20.0.0.225.

Any advice?

Best regards,

Leo

TOPICS
Air beta

Views

609

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 01, 2016 0
Adobe Employee ,
Feb 01, 2016

Copy link to clipboard

Copied

Hi,

This is a known issue and we are working on the same to fix it.

Please see the release notes it has been mentioned as a known issue: http://fpdownload.macromedia.com/pub/labs/flashruntimes/shared/air21_flashplayer21_releasenotes.pdf

-Roshan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
Explorer ,
Feb 01, 2016

Copy link to clipboard

Copied

Hi Roshan,

Thank you for your prompt reply.

I may add that I'm experiencing the same error, but I'm targeting Desktop only, and it happens after the Application has started, only on the non-primordial workers. By reading the Known Issues, this was not clear, and did not seem to affect Desktop deployments.

Looking forward for a solution.

Best regards,

Leo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
Explorer ,
Feb 02, 2016

Copy link to clipboard

Copied

I am able to compile on a windows machine, but it will fail to install on iOS. Does anyone have the same problem?

AIR 19 is the last stable one for me, as AIR 20 also has install issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2016 0
Adobe Employee ,
Feb 03, 2016

Copy link to clipboard

Copied

Hi geretti‌,

We may be able to help you with the issue. Kindly share me your email id here.

-Roshan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2016 0
geretti LATEST
Explorer ,
Feb 03, 2016

Copy link to clipboard

Copied

‌i private messaged you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2016 1