Highlighted

AIR download prompt despite packaging with captive runtime

New Here ,
Mar 14, 2016

Copy link to clipboard

Copied

I've recently encountered an issue where some android devices prompt user to download Adobe AIR despite packaging my app with captive runtime.

Has anyone encountered a similar issue or has any idea where to look for a solution?

To my knowledge this issue appears on Nexus 5 and LG G Flex models (probably more) and seems to be model specific - not an issue with particular devices.

The prompt requires the user to install Adobe AIR after every single update.

I have tried packaging with different versions of the SDK (19, 20 and 21) and to no effect - the issue persists on the same devices.

The issue appeared first just before the weekend. I've previously submitted builds with captive runtime using the same configuration on AIR 20 and had no such problem.

I'm using Flash Builder on a win 8 system and I am packaging via the windowed mode, not the command line.

I have several ANE's in my project, however none of them are currently linked nor are they packaged with the app.

This issue also affects my ability to publish to Amazon because of a custom prompt being displayed at the start of the application.

TOPICS
Performance issues

Views

150

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AIR download prompt despite packaging with captive runtime

New Here ,
Mar 14, 2016

Copy link to clipboard

Copied

I've recently encountered an issue where some android devices prompt user to download Adobe AIR despite packaging my app with captive runtime.

Has anyone encountered a similar issue or has any idea where to look for a solution?

To my knowledge this issue appears on Nexus 5 and LG G Flex models (probably more) and seems to be model specific - not an issue with particular devices.

The prompt requires the user to install Adobe AIR after every single update.

I have tried packaging with different versions of the SDK (19, 20 and 21) and to no effect - the issue persists on the same devices.

The issue appeared first just before the weekend. I've previously submitted builds with captive runtime using the same configuration on AIR 20 and had no such problem.

I'm using Flash Builder on a win 8 system and I am packaging via the windowed mode, not the command line.

I have several ANE's in my project, however none of them are currently linked nor are they packaged with the app.

This issue also affects my ability to publish to Amazon because of a custom prompt being displayed at the start of the application.

TOPICS
Performance issues

Views

151

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 14, 2016 0

Have something to add?

Join the conversation