Highlighted

AIR for iOS application crashes with sig 11 after update to air 17.0

New Here ,
Aug 25, 2015

Copy link to clipboard

Copied

I have an app that I am trying to update.

The last air sdk used was 3.8 and now I am trying to get it to work with 17.0

I am using command line to compile, package, and install app on an iPad which all seem to work just fine.

When I run the app, it crashes pretty quickly. Crash report says Exception Type: EXC_BAD_ACCESS.

I though it might be related to the anes so I removed all of those and am still having issues.

When I hook it up to to fdb and use "catch *" sometimes I will get

"[Fault] exception, information=ReferenceErro: Error #1065: Variable FlexVersion is not defined.

Fault, SpriteAsset() at SpreteAsset.as:131

     if (appDomain.hasDefinition("mx.core:FlexVersion"))

Other times it will just terminate with no information.

Any ideas what I am doing wrong?

am using 17.0 namespace, flex 4.6, target-player is 17 and swf-version is 28.

TOPICS
Development

Views

145

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

AIR for iOS application crashes with sig 11 after update to air 17.0

New Here ,
Aug 25, 2015

Copy link to clipboard

Copied

I have an app that I am trying to update.

The last air sdk used was 3.8 and now I am trying to get it to work with 17.0

I am using command line to compile, package, and install app on an iPad which all seem to work just fine.

When I run the app, it crashes pretty quickly. Crash report says Exception Type: EXC_BAD_ACCESS.

I though it might be related to the anes so I removed all of those and am still having issues.

When I hook it up to to fdb and use "catch *" sometimes I will get

"[Fault] exception, information=ReferenceErro: Error #1065: Variable FlexVersion is not defined.

Fault, SpriteAsset() at SpreteAsset.as:131

     if (appDomain.hasDefinition("mx.core:FlexVersion"))

Other times it will just terminate with no information.

Any ideas what I am doing wrong?

am using 17.0 namespace, flex 4.6, target-player is 17 and swf-version is 28.

TOPICS
Development

Views

146

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 25, 2015 0

Have something to add?

Join the conversation