Highlighted

Android AIR 19 SoftKeyboardBehavior "none" doesn't work.

Engaged ,
Nov 02, 2015

Copy link to clipboard

Copied

I'm building an App for iOS and Android using AIR 19 with Starling/Feathers.

I'm trying to disable the autopanning for the softkeyboard.. by using:

<softKeyboardBehavior>none</softKeyboardBehavior>

This is ONLY working for iOS for me, on Android no matter what the app will pan.

Does anyone else have this problem?

TOPICS
Development

Views

332

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Android AIR 19 SoftKeyboardBehavior "none" doesn't work.

Engaged ,
Nov 02, 2015

Copy link to clipboard

Copied

I'm building an App for iOS and Android using AIR 19 with Starling/Feathers.

I'm trying to disable the autopanning for the softkeyboard.. by using:

<softKeyboardBehavior>none</softKeyboardBehavior>

This is ONLY working for iOS for me, on Android no matter what the app will pan.

Does anyone else have this problem?

TOPICS
Development

Views

333

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 02, 2015 0
Engaged ,
Nov 02, 2015

Copy link to clipboard

Copied

A bit of a work-around, but perhaps try setting the "are of interest" area on Android so that the keyboard doesn't pan?  It's a bit of a pain, but it might work?

See TextField.softKeyboardInputAreaOfInterest

Interestingly it looks like other people have had the complete opposite problem!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2015 0