Highlighted

App Crashing after AIR 15 upgrade

Community Beginner ,
Sep 25, 2014

Copy link to clipboard

Copied

Hi,

I've developed an app that I was about to submit to the App store.  I've just upgraded to AIR 15 and installed using rsync, following  instructions here.  I'm using Flash Builder 4.6.

I can create the ipa and run in debug mode, either on my mac or on my iphone 5 (running ios 7). But when I upload to TestFlight and then download onto my phone, the app crashes.  It opens, I see a white screen, and then it immediately closes.  When I check the crash test report on TestFlight, it doesn't show any crashes.

I'm trying to figure out if there is some setting that I have wrong.  I've set this line in my app descriptor:

<application xmlns="http://ns.adobe.com/air/application/15.0">


When I tried to export a release build for android, I got this error:

/bin-release-temp/WordSlider-app.xml: error 102: Invalid namespace

http://ns.adobe.com/air/application/15.0


Anyone seen this or know what to do?

TIA

David

TOPICS
Air beta

Views

2.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

App Crashing after AIR 15 upgrade

Community Beginner ,
Sep 25, 2014

Copy link to clipboard

Copied

Hi,

I've developed an app that I was about to submit to the App store.  I've just upgraded to AIR 15 and installed using rsync, following  instructions here.  I'm using Flash Builder 4.6.

I can create the ipa and run in debug mode, either on my mac or on my iphone 5 (running ios 7). But when I upload to TestFlight and then download onto my phone, the app crashes.  It opens, I see a white screen, and then it immediately closes.  When I check the crash test report on TestFlight, it doesn't show any crashes.

I'm trying to figure out if there is some setting that I have wrong.  I've set this line in my app descriptor:

<application xmlns="http://ns.adobe.com/air/application/15.0">


When I tried to export a release build for android, I got this error:

/bin-release-temp/WordSlider-app.xml: error 102: Invalid namespace

http://ns.adobe.com/air/application/15.0


Anyone seen this or know what to do?

TIA

David

TOPICS
Air beta

Views

2.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 25, 2014 0
New Here ,
Oct 02, 2014

Copy link to clipboard

Copied

I had similar crashes with AIR 15, until I realized that the new compiler is now by default.

And the new compiler has some known issues: AIR compiler known issues

Now that I compile using the -useLegacyAOT=yes option (Re: unknown configuration variable 'useLegacyAOT'), everything works as before.

-Mathieu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2014 1
Adobe Employee ,
Oct 05, 2014

Copy link to clipboard

Copied

Hi,

Thanks for reporting the issue.

However, we will need some more details about these errors or crashes for further investigation. It will be great if you could share your application with us.

Best Regards,

Jitender

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 05, 2014 0
Community Beginner ,
Oct 08, 2014

Copy link to clipboard

Copied

Thanks for the replies. I'm now working on eliminating things that might be causing the problem. One suspect is one of the .ane's I'm using. If I cannot isolate the problem after some more work I'll post here and will be happy to send the project.  I'm using Starling, btw.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 08, 2014 0
Community Beginner ,
Oct 09, 2014

Copy link to clipboard

Copied

Hi Jitender,

OK I've done everything I can think to do.  Still crashing, now when I've delivered it via testflight onto my iphone 5 (running ios 7). Where do I send it?

Thanks,

David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2014 0
Adobe Employee ,
Oct 09, 2014

Copy link to clipboard

Copied

Hi David,

We have fixed a crasher in our Latest SDK that will be available to you most probably by tomorrow

Could you please try with new SDK once, if issue still persist you can upload the project on drop box and share the link with us or you can email the link on jthakur@adobe.com.

Regards,

Jitender

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2014 0
Community Beginner ,
Oct 16, 2014

Copy link to clipboard

Copied

I haven't seen any beta releases after October 2nd on the site... do you know when the new beta with fixes will be available?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2014 0
Advocate ,
Nov 19, 2014

Copy link to clipboard

Copied

I too have been experiencing the same crashing. Unfortunately, despite inserting a lot of try/catch statements at points where I thought it might raise the problem, no luck. And I haven't had the problem when I'm in the authoring environment, solely when the program is distributed to users. I have dropped back to 14 and that seems to have solved the crashing. I only wish I were more help in locating where the problem is but it's definitely happening to me (I was using the AIR 15 install from Apache Flex SDK Installer).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2014 0
New Here ,
Oct 10, 2014

Copy link to clipboard

Copied

brighttext Can you try to build a version with the -useLegacyAOT yes? So you use the old legacy compile. I've had the same problem, when making a release version the app crashed on startup. But when making a version with the old compiler, it does work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2014 0
Community Beginner ,
Oct 10, 2014

Copy link to clipboard

Copied

Timbowicz I can't see how to do that in the FB 4.6 IDE. It's not a Flex project; it's an actionscript project. The above link said to try


Project -> Properties -> Flex Build Packaging -> Apple iOS -> Customize Launch

So I'm looking for

Project -> Properties -> ActionScript Build Packaging -> Apple iOS -> Customize Launch   --  but there is no such thing. Pretty sure this isn't available in FB 4.6?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 10, 2014 0