Highlighted

Blank screen when 'abusing' device rotation on iOS?

Explorer ,
Jul 20, 2014

Copy link to clipboard

Copied

Hey i'm having a bug with (maybe) resize events with my app on iPhone 5 / iOS7 and simulator, the UI is adapting to any screen size ( different orientations )

I'm not doing anything fancy, UI is classic flash display list and it changes layout perfectly on resize event, or well, i thought it did until now!

The case where it doesnt work --> ***and ends up in a blank screen***, is if i fire a lot of device orientation changes *at the same time as the application launches*

( literally spamming it while the launch image is up )

I suspect a Flash Player bug here? cause if do the same thing afterwards, once the launch image is gone, the UI adapts perfectly

Anyone having the same problem? ( easy to test : just spam loads of orientation changes right after you launch your app, my bug reproduces both on simulator and real devices )

Thanks

TOPICS
Performance issues

Views

189

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Blank screen when 'abusing' device rotation on iOS?

Explorer ,
Jul 20, 2014

Copy link to clipboard

Copied

Hey i'm having a bug with (maybe) resize events with my app on iPhone 5 / iOS7 and simulator, the UI is adapting to any screen size ( different orientations )

I'm not doing anything fancy, UI is classic flash display list and it changes layout perfectly on resize event, or well, i thought it did until now!

The case where it doesnt work --> ***and ends up in a blank screen***, is if i fire a lot of device orientation changes *at the same time as the application launches*

( literally spamming it while the launch image is up )

I suspect a Flash Player bug here? cause if do the same thing afterwards, once the launch image is gone, the UI adapts perfectly

Anyone having the same problem? ( easy to test : just spam loads of orientation changes right after you launch your app, my bug reproduces both on simulator and real devices )

Thanks

TOPICS
Performance issues

Views

190

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 20, 2014 0

Have something to add?

Join the conversation