Highlighted

Camera issue on desktop (Win10)

New Here ,
Apr 26, 2019

Copy link to clipboard

Copied

Hi,

I'm maintaining large app that among other things enables user to capture image with the camera or scan QR codes also using feed from the camera. After around 30 camera activations I stop getting feed from camera.

To exclude possibility that it has to do anything with the rest of my code I built very simple one component app just for testing. This is the code.

After opening and closing camera feed for 75 times it stops "returning" image. I also tried profiling with Scout to see if there are possible memory leaks but I didn't recognise any. Here is profiling session with Scout.

The only difference I noticed between instances of Camera object when camera feed is visible and when it's not any more visible is that currentFPS property of those instances have different values. When things work fine currentFPS was larger than 0 and after feed was lost that property had value of 0.

I'm using latest version of AIR 32. Also, important thing, this issue occurs only on devices running Windows 10 (tried on both Pro and Home versions). When running on macOS I managed to open and close camera feed for more that 200 times and it was still working.

Any help would be much appreciated.

Thank you

TOPICS
Performance issues

Views

129

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Camera issue on desktop (Win10)

New Here ,
Apr 26, 2019

Copy link to clipboard

Copied

Hi,

I'm maintaining large app that among other things enables user to capture image with the camera or scan QR codes also using feed from the camera. After around 30 camera activations I stop getting feed from camera.

To exclude possibility that it has to do anything with the rest of my code I built very simple one component app just for testing. This is the code.

After opening and closing camera feed for 75 times it stops "returning" image. I also tried profiling with Scout to see if there are possible memory leaks but I didn't recognise any. Here is profiling session with Scout.

The only difference I noticed between instances of Camera object when camera feed is visible and when it's not any more visible is that currentFPS property of those instances have different values. When things work fine currentFPS was larger than 0 and after feed was lost that property had value of 0.

I'm using latest version of AIR 32. Also, important thing, this issue occurs only on devices running Windows 10 (tried on both Pro and Home versions). When running on macOS I managed to open and close camera feed for more that 200 times and it was still working.

Any help would be much appreciated.

Thank you

TOPICS
Performance issues

Views

130

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 26, 2019 0

Have something to add?

Join the conversation