Highlighted

CameraUi not working on iOS with AIR 18 or AIR 19. Crashes.

New Here ,
Aug 28, 2015

Copy link to clipboard

Copied

It simply crashes, when doing this:

if( CameraUI.isSupported )

               {

               var deviceCameraApp:CameraUI = new CameraUI();

                deviceCameraApp.addEventListener( MediaEvent.COMPLETE, imageCaptured );

                deviceCameraApp.addEventListener( Event.CANCEL, captureCanceled );

                deviceCameraApp.addEventListener( ErrorEvent.ERROR, cameraError );

                deviceCameraApp.launch( MediaType.IMAGE );

}

It shows the CameraUI, but it's black. And then it launches this error: [Fault] exception, information=ArgumentError: Error #3683: Texture too big (max is 2048x2048).

Any ideas?

TOPICS
Performance issues

Views

363

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CameraUi not working on iOS with AIR 18 or AIR 19. Crashes.

New Here ,
Aug 28, 2015

Copy link to clipboard

Copied

It simply crashes, when doing this:

if( CameraUI.isSupported )

               {

               var deviceCameraApp:CameraUI = new CameraUI();

                deviceCameraApp.addEventListener( MediaEvent.COMPLETE, imageCaptured );

                deviceCameraApp.addEventListener( Event.CANCEL, captureCanceled );

                deviceCameraApp.addEventListener( ErrorEvent.ERROR, cameraError );

                deviceCameraApp.launch( MediaType.IMAGE );

}

It shows the CameraUI, but it's black. And then it launches this error: [Fault] exception, information=ArgumentError: Error #3683: Texture too big (max is 2048x2048).

Any ideas?

TOPICS
Performance issues

Views

364

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 28, 2015 0
Adobe Employee ,
Aug 28, 2015

Copy link to clipboard

Copied

Hi interactivemartin,

What type of device is this happening with?  Do you also have a https://bugbase.adobe.com bug number that I can reference?

Thanks

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2015 0
New Here ,
Aug 28, 2015

Copy link to clipboard

Copied

IPhone 5s, iOs 8.4.1. No, there is no logged bug apparently. Should I log

one?

On Saturday, August 29, 2015, chris.campbell <forums_noreply@adobe.com>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2015 0
Adobe Employee ,
Aug 28, 2015

Copy link to clipboard

Copied

Thank you, and yes, please log a bug.  It's typically a far better way to track issues than the forum alone.

Anyone else running into issues here?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2015 0
Adobe Employee ,
Aug 31, 2015

Copy link to clipboard

Copied

Hi,

Thanks for reporting the issue.

We tried reproducing the problem at our end with the given code snippet but couldn't reproduce it, CameraUI is launched successfully and application behave fine.

We verified it on iPhone 6 (8.0) and iPhone 5s(8.4.1) both. so could you please share us the sample application that can reproduce the problem.

Regards,

Adobe AIR Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2015 0
New Here ,
Aug 31, 2015

Copy link to clipboard

Copied

I added more info in the bug database.

If you use JRE 8.0 to copile and JDK 8.0, it happens. I had to revert to 6.0, for another reason, and now it is working. What version of JAVA is the recomended one to compile propertly?

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2015 0