Highlighted

Could not resolve <s:ViewNavigatorApplication> to a component implementation.

New Here ,
May 07, 2015

Copy link to clipboard

Copied

Hello.

I'm developing an mobile app,for android and ios.

We started to develop the app using air 3.5 and everything were working fine.

Recently i've updated my AIR SDK to 17 version and since then i can't build my project because of this error "Could not resolve <s:ViewNavigatorApplication> to a component implementation.".

I already searched on web about this problem but i didn't found anything that solved the problem.

Does anyone have the same problem?

How do you solved this?

Thanks

TOPICS
Development

Views

330

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Could not resolve <s:ViewNavigatorApplication> to a component implementation.

New Here ,
May 07, 2015

Copy link to clipboard

Copied

Hello.

I'm developing an mobile app,for android and ios.

We started to develop the app using air 3.5 and everything were working fine.

Recently i've updated my AIR SDK to 17 version and since then i can't build my project because of this error "Could not resolve <s:ViewNavigatorApplication> to a component implementation.".

I already searched on web about this problem but i didn't found anything that solved the problem.

Does anyone have the same problem?

How do you solved this?

Thanks

TOPICS
Development

Views

331

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 07, 2015 0
Participant ,
May 07, 2015

Copy link to clipboard

Copied

This sounds like an AIR SDK width FLEX SDK overlaying issue. You probably have downloaded the wrong AIR SDK, which is not compatible with the Flex SDK. Check if you downloaded the correct AIR SDK for Flex (see here: Download Adobe AIR SDK ->  Note: Flex users will need to download the original AIR SDK without the new compiler - download links follow below this).
Alternatively I reccomend you to download the Flex SDK Installer and install both SDKs with it. You won't have to manually overlay both SDKs in this case.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2015 0
jcvfc LATEST
New Here ,
May 11, 2015

Copy link to clipboard

Copied

I already did that,and the error it's the same.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2015 0