Highlighted

Debug works fine, Export Application crashes on iOS 8.3

New Here ,
Jun 18, 2015

Copy link to clipboard

Copied

Hello,

I work on a project, it's a mobile application for Android and iOS.

It's a presentation application simple, there is only screens with content.

There is no problem during developement.

Everything works fine in debug mode on both platforms.

Everything is okay on Android, exportation is done and new version of the application is online.

When I export application for Apple it's very bad.

The build of file is okay in ipa-app-store or ipa-ad-hoc

With the latests versions of AIR (after 15.0), Application works for debug

If application is run on phone, it crashes after loading all elements.

I tried with -useLegacy=yes or not, there is no changes

With the oldest version of AIR (before 15.0 included), Application works for debug

Application works fine on phone, but Apple don't want I sent this version

because it's not "64-bit support "

Is anybody meets the same problem ?

Is there a solution for publish my update?

Thanks

JB

TOPICS
Performance issues

Views

531

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Debug works fine, Export Application crashes on iOS 8.3

New Here ,
Jun 18, 2015

Copy link to clipboard

Copied

Hello,

I work on a project, it's a mobile application for Android and iOS.

It's a presentation application simple, there is only screens with content.

There is no problem during developement.

Everything works fine in debug mode on both platforms.

Everything is okay on Android, exportation is done and new version of the application is online.

When I export application for Apple it's very bad.

The build of file is okay in ipa-app-store or ipa-ad-hoc

With the latests versions of AIR (after 15.0), Application works for debug

If application is run on phone, it crashes after loading all elements.

I tried with -useLegacy=yes or not, there is no changes

With the oldest version of AIR (before 15.0 included), Application works for debug

Application works fine on phone, but Apple don't want I sent this version

because it's not "64-bit support "

Is anybody meets the same problem ?

Is there a solution for publish my update?

Thanks

JB

TOPICS
Performance issues

Views

532

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 18, 2015 0
Advocate ,
Jun 19, 2015

Copy link to clipboard

Copied

do you use AIR 18.0.0.143/144?

Also there is nothing to do with useLegacy tag because it deprecated and any ipa's created now using fast compiler option. Try to determinate memory issue using Adobe Scout. Looks like your app upload into the memory too much. Or you created it using Flash Pro or your main SWF is a huge and you don't use external resource loading technique

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2015 0
New Here ,
Jun 19, 2015

Copy link to clipboard

Copied

I use AIR 18.0.0.143.

In Adobe Scout, I don't see any error or something strange compared to development version.

The app has been developed last year. The app was published and works well on iOS 7
This year, it is just a little update with content.
It's running fine on iOS 8.3 when built with AIR 14. 
But it crashes with newest version.



Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2015 0
Adobe Employee ,
Jun 25, 2015

Copy link to clipboard

Copied

Hi FLASHJB

We tried to reproduce the issue on iOS device. Exported a sample application using AIR SDK 18.0.0.143 and installed .

The app runs fine without any crash at our end.

Please let us know the following.

1. Which phone does the app runs on? is it on all the iOS devices ?

2. Can you reproduce the issue on any OS other than 8.3 ?

3. Are you using any ANE with your application ?

4.Can you share a sample app with us at : chhetri@adobe.com to reproduce the issue at our end?

Roshan

Adobe Air

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2015 0