Highlighted

dx tool failed (com.android.dx.cf.code.SimException) unable to build ane with java8

Explorer ,
Oct 05, 2018

Copy link to clipboard

Copied

we are getting **dx tool failed** error when compiling apk with ane that based on mapbox android sdk with java 1.8 compability.

We are successfully generating ane but unable to build apk. using jdk 1.8.0_181 64bit(tried other version and jre) android build tool 28 also min sdk version is 27 adobe air windows sdk 31.0.96 (latest) also tried replacing old adobe air dx.jar as described in another adobe bugtrack https://tracker.adobe.com/#/view/AIR-4198726 tried all dx.jars including api28 but result is same.

also tried with latest java 10 JDK 10.0.2

dx tool failed:WARNING in com.mapbox.mapboxsdk.log.LoggerDefinition.log:(ILjava/lang/String;Ljava /lang/String;)V:

defining a static interface method requires --min-sdk-version >= 24 (currently 13) for interface methods:

com.mapbox.mapboxsdk.log.LoggerDefinition.log:(ILjava/lang/String;Ljava /lang/String;)

Uncaught translation error: com.android.dx.cf.code.SimException: ERROR in

com.mapbox.mapboxsdk.http.NativeHttpRequest.executeLocalRequest:(Ljava/lang/String;)V:

invalid opcode ba - invokedynamic requires --min-sdk-version >= 26 (currently 13)

Uncaught translation error: com.android.dx.cf.code.SimException: ERROR in

com.mapbox.mapboxsdk.log.Logger.log:(ILjava/lang/String;Ljava/lang/String;)V:

invoking a static interface method com.mapbox.mapboxsdk.log.LoggerDefinition.log:(ILjava/lang /String;Ljava/lang/String;)

strictly requires --min-sdk-version >= 24 (blocked at current API level 13)

Uncaught translation error: com.android.dx.cf.code.SimException: ERROR in

com.mapbox.mapboxsdk.maps.MapView.initialiseDrawingSurface:(Lcom/mapbox/mapboxsdk /maps/MapboxMapOptions;)V:

invalid opcode ba - invokedynamic requires --min-sdk-version >= 26 (currently 13) 3 errors; aborting

please vote for this bug Tracker

TOPICS
Development

Views

636

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

dx tool failed (com.android.dx.cf.code.SimException) unable to build ane with java8

Explorer ,
Oct 05, 2018

Copy link to clipboard

Copied

we are getting **dx tool failed** error when compiling apk with ane that based on mapbox android sdk with java 1.8 compability.

We are successfully generating ane but unable to build apk. using jdk 1.8.0_181 64bit(tried other version and jre) android build tool 28 also min sdk version is 27 adobe air windows sdk 31.0.96 (latest) also tried replacing old adobe air dx.jar as described in another adobe bugtrack https://tracker.adobe.com/#/view/AIR-4198726 tried all dx.jars including api28 but result is same.

also tried with latest java 10 JDK 10.0.2

dx tool failed:WARNING in com.mapbox.mapboxsdk.log.LoggerDefinition.log:(ILjava/lang/String;Ljava /lang/String;)V:

defining a static interface method requires --min-sdk-version >= 24 (currently 13) for interface methods:

com.mapbox.mapboxsdk.log.LoggerDefinition.log:(ILjava/lang/String;Ljava /lang/String;)

Uncaught translation error: com.android.dx.cf.code.SimException: ERROR in

com.mapbox.mapboxsdk.http.NativeHttpRequest.executeLocalRequest:(Ljava/lang/String;)V:

invalid opcode ba - invokedynamic requires --min-sdk-version >= 26 (currently 13)

Uncaught translation error: com.android.dx.cf.code.SimException: ERROR in

com.mapbox.mapboxsdk.log.Logger.log:(ILjava/lang/String;Ljava/lang/String;)V:

invoking a static interface method com.mapbox.mapboxsdk.log.LoggerDefinition.log:(ILjava/lang /String;Ljava/lang/String;)

strictly requires --min-sdk-version >= 24 (blocked at current API level 13)

Uncaught translation error: com.android.dx.cf.code.SimException: ERROR in

com.mapbox.mapboxsdk.maps.MapView.initialiseDrawingSurface:(Lcom/mapbox/mapboxsdk /maps/MapboxMapOptions;)V:

invalid opcode ba - invokedynamic requires --min-sdk-version >= 26 (currently 13) 3 errors; aborting

please vote for this bug Tracker

TOPICS
Development

Views

637

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 05, 2018 0

Have something to add?

Join the conversation