Highlighted

error 402: Current Android sdk version doesn't support uses-permission-sdk-23 as xml tag

Contributor ,
Jan 31, 2018

Copy link to clipboard

Copied

We want to include this in the android manifest:

<uses-permission-sdk-23 android:name=“android.permission.READ_EXTERNAL_STORAGE”/>

This would allow us to ask for the permission only in the new Android permissions model, but without requiring it for Android versions < 6.0, since the new permission would prevent some people from installing the update.

But when I try to package for android, I get this error:

[java] /Users/me/path/to/project/bin-release-temp/Main-app.xml: error 402: Current Android sdk version doesn't support uses-permission-sdk-23 as xml tag

This is with AIR SDK 28 and the latest stable Android SDK, version 7.0. Am I missing something, or is there a way around this?

Hi Peter,

This issue has been fixed with our latest Beta. Please use latest AIR SDK 29 from https://labs.adobe.com/downloads/air.html and let us know if it works for you.

Regards,

Adobe AIR Team

TOPICS
Air beta

Views

718

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

error 402: Current Android sdk version doesn't support uses-permission-sdk-23 as xml tag

Contributor ,
Jan 31, 2018

Copy link to clipboard

Copied

We want to include this in the android manifest:

<uses-permission-sdk-23 android:name=“android.permission.READ_EXTERNAL_STORAGE”/>

This would allow us to ask for the permission only in the new Android permissions model, but without requiring it for Android versions < 6.0, since the new permission would prevent some people from installing the update.

But when I try to package for android, I get this error:

[java] /Users/me/path/to/project/bin-release-temp/Main-app.xml: error 402: Current Android sdk version doesn't support uses-permission-sdk-23 as xml tag

This is with AIR SDK 28 and the latest stable Android SDK, version 7.0. Am I missing something, or is there a way around this?

Hi Peter,

This issue has been fixed with our latest Beta. Please use latest AIR SDK 29 from https://labs.adobe.com/downloads/air.html and let us know if it works for you.

Regards,

Adobe AIR Team

TOPICS
Air beta

Views

719

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 31, 2018 0
Adobe Employee ,
Feb 01, 2018

Copy link to clipboard

Copied

Hello Peter,

Thanks for reporting we are investigating this issue.

Regards,

Adobe AIR Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2018 0
Adobe Employee ,
Feb 15, 2018

Copy link to clipboard

Copied

Hi Peter,

This issue has been fixed with our latest Beta. Please use latest AIR SDK 29 from https://labs.adobe.com/downloads/air.html and let us know if it works for you.

Regards,

Adobe AIR Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2018 0