Highlighted

flash security sandbox

Explorer ,
Oct 22, 2016

Copy link to clipboard

Copied

Hi all,

i had some problems with security sandbox of Flash Player when I have a Socket server developed with Adobe Air and Flash client (embbed in an html page).

exemple:

server : localhost:8087

client : https://myipdomain/games

result:

Os:WIndows 10

Google Crhome :working

Firefox:working

IE 11:working

Edge :Not working - Error :2048

Adobe Air Server policy:

var policy:String = '<cross-domain-policy><allow-access-from domain="*" to-ports="8087" /></cross-domain-policy>\x00';

Microsoft Edge has disabled loopback localhost for WebSockets.

In the Microsoft Edge browser type "About: flags" in the title bar is to enable loopback.!

It is a big mistake. Since the future of the plugin is using the socket with installed programs!

TOPICS
Development

Views

362

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

flash security sandbox

Explorer ,
Oct 22, 2016

Copy link to clipboard

Copied

Hi all,

i had some problems with security sandbox of Flash Player when I have a Socket server developed with Adobe Air and Flash client (embbed in an html page).

exemple:

server : localhost:8087

client : https://myipdomain/games

result:

Os:WIndows 10

Google Crhome :working

Firefox:working

IE 11:working

Edge :Not working - Error :2048

Adobe Air Server policy:

var policy:String = '<cross-domain-policy><allow-access-from domain="*" to-ports="8087" /></cross-domain-policy>\x00';

Microsoft Edge has disabled loopback localhost for WebSockets.

In the Microsoft Edge browser type "About: flags" in the title bar is to enable loopback.!

It is a big mistake. Since the future of the plugin is using the socket with installed programs!

TOPICS
Development

Views

363

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 22, 2016 0
Explorer ,
Oct 23, 2016

Copy link to clipboard

Copied

Try to set server on real IP not localhost nor 127.0.0.1.

Sandbox could not allow connection to localhost (127.0.0.1) for security reasons.

I did not test it but it could be reasonable.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2016 0
Explorer ,
Oct 23, 2016

Copy link to clipboard

Copied

Microsoft Edge has disabled loopback localhost for WebSockets.

In the Microsoft Edge browser type "About: flags" in the title bar is to enable loopback.!

It is a big mistake. Since the future of the plugin is using the socket with installed programs!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2016 0