Highlighted

Help Needed basic Flash created IPA is only displaying black screen on Ipad

Community Beginner ,
Jul 17, 2015

Copy link to clipboard

Copied

After sending days jumping the 17 thousand flaming hoops that Apple makes you do, i got my p12 and user profile and was able to make an IPA on my PC and then moved it by USB to my Mac added to the Apps, synced and uploaded to Ipad2 only for the App to display only a black screen.

I know its reading something as the time and power still display and when i did it a second time and published as Iphone the App showed a black screen but was zoomed in (i.e. time and battery bigger). It seems to not be reading the swf, but thats a guess. The App is nothing more than a simple moving box as i wanted to test i could get it from PC to Ipad before building any further.

ANy help would be greatly appreciated as this is for my work.

TOPICS
Development

Views

159

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Help Needed basic Flash created IPA is only displaying black screen on Ipad

Community Beginner ,
Jul 17, 2015

Copy link to clipboard

Copied

After sending days jumping the 17 thousand flaming hoops that Apple makes you do, i got my p12 and user profile and was able to make an IPA on my PC and then moved it by USB to my Mac added to the Apps, synced and uploaded to Ipad2 only for the App to display only a black screen.

I know its reading something as the time and power still display and when i did it a second time and published as Iphone the App showed a black screen but was zoomed in (i.e. time and battery bigger). It seems to not be reading the swf, but thats a guess. The App is nothing more than a simple moving box as i wanted to test i could get it from PC to Ipad before building any further.

ANy help would be greatly appreciated as this is for my work.

TOPICS
Development

Views

160

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 17, 2015 0
Adobe Community Professional ,
Jul 17, 2015

Copy link to clipboard

Copied

Did you do a test movie on your PC? It seems likely that there's a script error going on.

Here's an old article on doing device debugging, which should work for PCs too. I wouldn't be surprised if it just doesn't work by now, but I can't check. Do you not get a Debug/Debug Movie/On Device via USB option? Anyway, the old article is here:

Debugging AIR applications over USB on iOS

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 17, 2015 0
Community Beginner ,
Jul 19, 2015

Copy link to clipboard

Copied

Hi Colin,

Thanks for getting back to me. I definitely tested on my PC. It is a very very basic animation, literally a cycle moving left to right for 30 frames. That is it has no buttons or scripts just an animation. I thought i would start there and once i could get that to work increase the complexity testing along the way.

I haven't tried the link yet, i will shortly.

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2015 0
New Here ,
Jul 20, 2015

Copy link to clipboard

Copied

Could you have a look at the generated ipa file?

I think you can actually open it with a zip tool ... it should contain a "Payload/yourappname.app" directory with a binary "yourappname" (Just replace "yourappname" with your app name 😉 ). I am currently having trouble too and I could see that the application executable seems to be 0 byte big. In my case the symptom is that the icon becomes black/dark and nothing happens. Just want to make sure we're not having the same problem 🙂

I just posted my question yesterday: IPA file generated by ADT contains 0 byte executable

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2015 0