Highlighted

How do I set CFBundleVersion in AIR

New Here ,
Sep 26, 2014

Copy link to clipboard

Copied

Hello, I am making an AIR app for my client.

When my client upload the iTunes Connect to submit their app again( because it have some error at the first time), they received an error. It said

--

ERROR ITMS-9000: "Redundant Binary Upload. There already exists a binary upload with build version '3.0.2' for train '3.0.2'

--

I tried to resolve this and search the web. I found the solution

--

ERROR ITMS-9000: “Redundant Binary Upload. There already exists a binary upload with build version '1.0' for train '1.0'”

http://stackoverflow.com/questions/25680604/error-itms-9000-redundant-binary-upload-there-already-ex...

--

The solution is to change the "build" number of app not the "version" number.

We can change the version number but cannot change the build number with application settings xml file in AIR development.

versionNumber property in application xml is assigned to both CFBundleShortVersionString and CFBundleVersion in Info.plist

CFBundleShortVersionString is used for version number

CFBundleVersion is used for build number

If I set versionNumber, packager set both CFBundleShortVersionString and CFBundleVersion automatically. I tried versionLabel property in application settings xml, but it is no mean. I also tried to this.

rename .ipa file to .zip file

unzip it

set CFBundleVersion to other number in Info.plist in Payload/app.app directory

zip it again

and upload it to iTunes connect by application loader

but application loader said

--

ERROR ITMS-9000: "Missing or invalid signature. The bundle 'xxxxxx.xxxxx.xxxx.appname' at bundle path 'Payload/appname.app' is not signed using an Apple submission certificate'

--

How can I set the CFBundleVersion?

I found the same problem here in Adobe's discussion.

How do I set the CFBundleVersion value of my App in Flex

https://forums.adobe.com/thread/1036926?start=0&tstart=0

But unfortunately  it had not been resolved.

I want to change only the build number but the version number if it is possible.

Thanks in advance.

TOPICS
Development

Views

939

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How do I set CFBundleVersion in AIR

New Here ,
Sep 26, 2014

Copy link to clipboard

Copied

Hello, I am making an AIR app for my client.

When my client upload the iTunes Connect to submit their app again( because it have some error at the first time), they received an error. It said

--

ERROR ITMS-9000: "Redundant Binary Upload. There already exists a binary upload with build version '3.0.2' for train '3.0.2'

--

I tried to resolve this and search the web. I found the solution

--

ERROR ITMS-9000: “Redundant Binary Upload. There already exists a binary upload with build version '1.0' for train '1.0'”

http://stackoverflow.com/questions/25680604/error-itms-9000-redundant-binary-upload-there-already-ex...

--

The solution is to change the "build" number of app not the "version" number.

We can change the version number but cannot change the build number with application settings xml file in AIR development.

versionNumber property in application xml is assigned to both CFBundleShortVersionString and CFBundleVersion in Info.plist

CFBundleShortVersionString is used for version number

CFBundleVersion is used for build number

If I set versionNumber, packager set both CFBundleShortVersionString and CFBundleVersion automatically. I tried versionLabel property in application settings xml, but it is no mean. I also tried to this.

rename .ipa file to .zip file

unzip it

set CFBundleVersion to other number in Info.plist in Payload/app.app directory

zip it again

and upload it to iTunes connect by application loader

but application loader said

--

ERROR ITMS-9000: "Missing or invalid signature. The bundle 'xxxxxx.xxxxx.xxxx.appname' at bundle path 'Payload/appname.app' is not signed using an Apple submission certificate'

--

How can I set the CFBundleVersion?

I found the same problem here in Adobe's discussion.

How do I set the CFBundleVersion value of my App in Flex

https://forums.adobe.com/thread/1036926?start=0&tstart=0

But unfortunately  it had not been resolved.

I want to change only the build number but the version number if it is possible.

Thanks in advance.

TOPICS
Development

Views

940

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 26, 2014 0
Explorer ,
Sep 27, 2014

Copy link to clipboard

Copied

I'm joining this conversation because I need to know also.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2014 0
New Here ,
Sep 27, 2014

Copy link to clipboard

Copied

Finally I found the solution. But it takes too long time to fix it manually. So I made shell script and upload it in github.

KinkumaDesign/SetCFBundleVersionInAdobeAIR

https://github.com/KinkumaDesign/SetCFBundleVersionInAdobeAIR

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2014 0