Highlighted

Incorrect Splash Image on iPhone

Community Beginner ,
Oct 11, 2018

Copy link to clipboard

Copied

I want to use Splash Image in my iOS Adobe AIR app.

I've read this article:

Launch Images on iOS with Adobe AIR

I test my app on iPhone 7, so I included these two images

iPhone 5,5c,5s640×1136Default-568h@2x~iphone.pngPortrait
iPhone 6, 7, 8750×1334Default-375w-667h@2x~iphone.pngPortrait

When I start my app I see Splash Image for iPhone 5, 5c, 5s. Why? Is is a bug?

TOPICS
Performance issues

Views

283

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Incorrect Splash Image on iPhone

Community Beginner ,
Oct 11, 2018

Copy link to clipboard

Copied

I want to use Splash Image in my iOS Adobe AIR app.

I've read this article:

Launch Images on iOS with Adobe AIR

I test my app on iPhone 7, so I included these two images

iPhone 5,5c,5s640×1136Default-568h@2x~iphone.pngPortrait
iPhone 6, 7, 8750×1334Default-375w-667h@2x~iphone.pngPortrait

When I start my app I see Splash Image for iPhone 5, 5c, 5s. Why? Is is a bug?

TOPICS
Performance issues

Views

284

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 11, 2018 0
Community Beginner ,
Oct 15, 2018

Copy link to clipboard

Copied

Hi,

Thanks for reporting the issue, could you please recheck if images used by you are having naming convention and sizes are as per the documents as we are getting right Launch Image for iPhone 7. iPhone 7 picking up iPhone 5/5c/5s launch image can happen only in one case if you are missing iPhone 7 launch image at the time of packaging due to iPhone fallback property.

Thanks,

Amit Baliyan | Adobe AIR Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2018 0
subdan LATEST
Community Beginner ,
Oct 15, 2018

Copy link to clipboard

Copied

I checked again and in Portrait mode all is ok but in landscape mode I've found one big issue.

Transition from splash screen to Main screen goes through black screen with fade animation. Is it a bug? Will you fix it?

Video demo see here — https://drive.google.com/open?id=1KMTS-_rkip60S5SiCRSwvKAvgAOqrAjk

FLA + splash screen you can download here — https://drive.google.com/open?id=14B_W5Ra_tL7jHVg4Iv5FVNVrpscou55z

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2018 0