Highlighted

Installing Air 20 breaks ANE in situ (Mac only)

New Here ,
Dec 14, 2015

Copy link to clipboard

Copied

On Macs, we have several AIR applications that use ANE,

Installed and working correctly.

After installing Air 20, they no longer work.  When launched, the

error pop-up says "the required native extension is missing for this application."

It must be a bug if upgrading AIR turns a working application into a non-working one.

I'm looking for any information related to this problem.

TOPICS
Performance issues

Views

291

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Installing Air 20 breaks ANE in situ (Mac only)

New Here ,
Dec 14, 2015

Copy link to clipboard

Copied

On Macs, we have several AIR applications that use ANE,

Installed and working correctly.

After installing Air 20, they no longer work.  When launched, the

error pop-up says "the required native extension is missing for this application."

It must be a bug if upgrading AIR turns a working application into a non-working one.

I'm looking for any information related to this problem.

TOPICS
Performance issues

Views

292

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 14, 2015 0
Adobe Employee ,
Dec 14, 2015

Copy link to clipboard

Copied

Hi ddyer00,

Are your AIR ANE's 32-bit?  AIR 20 is 64-bit only, so you'll need to either update your ANE's, have customers roll back to AIR 19 (and disable updates), or create a captive runtime application using AIR 19 and distribute that.  Here's details on the change:

http://blogs.adobe.com/flashplayer/2015/12/air-64-bit-on-mac-osx.html

Thanks,

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2015 0
Participant ,
Dec 15, 2015

Copy link to clipboard

Copied

How do you roll back to AIR 19?  I upgraded to AIR 20 but it has broken Adobe Media Player which I use a lot.  If I can rollback, then I can continue to use AIR 19 for my needs.  I tried a download and install but that failed because a more recent version exists on my system.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2015 0
ddyer00 LATEST
New Here ,
Dec 15, 2015

Copy link to clipboard

Copied

Following up, trying to build 64 bit ANEs, according to

AIR 64-bit on Mac OSX

there's an essential component "air_64" packaged with the air 20 sdk.  I've got the new sdk but there is no air_64

in it.  So where do I find air_64?   The piece I'm apparently missing is the 64 bit library that supplies the

interface functions such as FRECallObjectMethod

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2015 0