Highlighted

iOS simulator broken with new updates

Contributor ,
Apr 03, 2018

Copy link to clipboard

Copied

I get an error when trying to build a simulator IPA for testing on OSx.

Here is the error:

ld: unexpected token: !tapi-tbd-v3 file '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/usr/lib/libc++.tbd' for architecture x86_64

Compilation failed while executing : ld64

I'm guessing this is related to updates to xcode, simulator, itunes etc...

Any direction greatly appreciated.

Thanks for looking,

-cybo

Hi,

Could you please try once with following workaround and let us know if things are working fine for you:

  • Replace the Runtime LD located at the path <AIRSDK>/lib/aot/bin/ld64/ld64 with the one which comes with Xcode 9.3.
  • You can find it at location: <Xcode9.3InstallDir>/Xcode.app/Contents/Developer/usr/bin/ld.

Also, do not forget to rename ld to ld64.

Thanks,

Pravishti | Adobe AIR Engineering

TOPICS
Performance issues

Views

3.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

iOS simulator broken with new updates

Contributor ,
Apr 03, 2018

Copy link to clipboard

Copied

I get an error when trying to build a simulator IPA for testing on OSx.

Here is the error:

ld: unexpected token: !tapi-tbd-v3 file '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/usr/lib/libc++.tbd' for architecture x86_64

Compilation failed while executing : ld64

I'm guessing this is related to updates to xcode, simulator, itunes etc...

Any direction greatly appreciated.

Thanks for looking,

-cybo

Hi,

Could you please try once with following workaround and let us know if things are working fine for you:

  • Replace the Runtime LD located at the path <AIRSDK>/lib/aot/bin/ld64/ld64 with the one which comes with Xcode 9.3.
  • You can find it at location: <Xcode9.3InstallDir>/Xcode.app/Contents/Developer/usr/bin/ld.

Also, do not forget to rename ld to ld64.

Thanks,

Pravishti | Adobe AIR Engineering

TOPICS
Performance issues

Views

3.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 03, 2018 2
Participant ,
Apr 03, 2018

Copy link to clipboard

Copied

I am experiencing the same issue. I am able to package for release, but I cannot package for debug on either device or in simulator. Full error:

ld: unexpected token: !tapi-tbd-v3 file '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/lib/libc++.tbd' for architecture arm64

ld: unexpected token: !tapi-tbd-v3 file '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/lib/libc++.tbd' for architecture armv7

Compilation failed while executing : ld64

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2018 0
Participant ,
Apr 05, 2018

Copy link to clipboard

Copied

Is there any update from Adobe regarding this? It's completely impossible to compile iOS currently.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 05, 2018 0
Contributor ,
Apr 05, 2018

Copy link to clipboard

Copied

Perhaps we can elevate it to the bug tracker? There must be lots of users experiencing this if it's not isolated to us.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 05, 2018 0
Adobe Employee ,
Apr 06, 2018

Copy link to clipboard

Copied

Hi,

Thanks for reporting this issue. We're currently investigating it and we'll keep you posted.

Thanks,

Pravishti | Adobe AIR Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2018 0
Contributor ,
Apr 06, 2018

Copy link to clipboard

Copied

Thanks Pravishti. Appreciate the hard work of you and your team.

-cybo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2018 0
Contributor ,
Apr 12, 2018

Copy link to clipboard

Copied

Hi Pravishti,

Any update on this issue?

-cybo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2018 0
Explorer ,
Apr 23, 2018

Copy link to clipboard

Copied

same issu for lates air sdk 29.122 on windows

forum support stuff's support sense is terrible really why it took ages ?)

such great tool and aweful support

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2018 0
Contributor ,
May 07, 2018

Copy link to clipboard

Copied

Hi Pravishti,

Is there any update on this issue or a workaround?

The simulator is a really powerful tool for testing on various iOS devices.

-cybo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 0
Adobe Community Professional ,
May 07, 2018

Copy link to clipboard

Copied

There is a workaround, Mohanaraj​ , can that be shared here?

Even with the work around there isn't an easy way to do iPhone X testing in the simulator, but I found a tolerable solution to that too. Here's the StackOverflow discussion I followed:

xcode - Is there a way to move my iOS Simulator app data from one simulator (iPhone 7) to another (i...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 2
Contributor ,
May 07, 2018

Copy link to clipboard

Copied

Hi Colin,

Fingers crossed that workaround can be shared.

What's the issue with iPhone X, before this error happened I'm pretty sure I was able to run it in the sim?

Thanks for the reply.

-cybo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 0
Adobe Community Professional ,
May 07, 2018

Copy link to clipboard

Copied

I can have Simulator open and running iPhone X, and still Animate launches a new iPhone 6 window. For now I use the trick to copy the IPA over to the iPhone X simulator folder, then I can test it. But, I haven't had success with a debug test yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 2
Contributor ,
May 07, 2018

Copy link to clipboard

Copied

I see, thanks for clarifying. Hopefully the workaround can be shared too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 0
Adobe Employee ,
May 07, 2018

Copy link to clipboard

Copied

Hi,

Could you please try once with following workaround and let us know if things are working fine for you:

  • Replace the Runtime LD located at the path <AIRSDK>/lib/aot/bin/ld64/ld64 with the one which comes with Xcode 9.3.
  • You can find it at location: <Xcode9.3InstallDir>/Xcode.app/Contents/Developer/usr/bin/ld.

Also, do not forget to rename ld to ld64.

Thanks,

Pravishti | Adobe AIR Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 2
Adobe Community Professional ,
May 07, 2018

Copy link to clipboard

Copied

What Pravishti said in message 13 is the workaround I mentioned.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 2
Contributor ,
May 08, 2018

Copy link to clipboard

Copied

Thanks Pravishti, that worked like a charm!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2018 0
Contributor ,
May 08, 2018

Copy link to clipboard

Copied

Thanks Colin, appreciate it!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2018 0
Adobe Employee ,
May 08, 2018

Copy link to clipboard

Copied

Hi Colin - Sorry, I'm bit late here but please feel free to share the workaround where ever required. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2018 0
Community Beginner ,
Sep 19, 2018

Copy link to clipboard

Copied

Unfortunately, a similar problem now pops up with AIR 31 and the latest Xcode 10.0 (which brings support for iPhone XR / XS Max simulators) — and here, that workaround with ld64 doesn't work any more (at least in my tests).

Im now getting the following error during compilation:

simulator-error.png

That seems related — that's why I'm posting it in this thread. Does anybody have an idea what could be done to fix this?

Thanks a lot in advance!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 2
Participant ,
Sep 23, 2018

Copy link to clipboard

Copied

I too am getting this same error....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2018 0
Adobe Community Professional ,
Sep 24, 2018

Copy link to clipboard

Copied

pravishtisMohanaraj​ Can you check this out? The work around in message 13 doesn't fix things anymore.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 24, 2018 1
Explorer ,
Oct 09, 2018

Copy link to clipboard

Copied

Similar issue. Must be number 1 priority AIR 31 and -platformsdk switch of iOS12 Beta - unable to compile

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2018 0
Participant ,
Dec 03, 2018

Copy link to clipboard

Copied

Is it possible to use the iOS iOS 12 simulators in Animate yet or not ? .. tried the work around - ld64 etc with AIR 32.0.0.83 but still no joy. Have you managed to figure a way ?.  When I copy the ld file from Xcode 10.1 its only 18k the adobe ld64 is 2.2mb .. not sure that is right ?.

Is a fix likely soon ? .. .I really rely on the sims , would be great to get this sorted well before xmas ..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2018 0
New Here ,
Apr 09, 2019

Copy link to clipboard

Copied

Any updates to this?

I'm getting the same error when trying to package an application using the `adt` commandline tool.

I'm new to AIR. I would very much appreciate any kind of help on this issue..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2019 0
Participant ,
Nov 02, 2018

Copy link to clipboard

Copied

Are we any nearer getting a solution for this ?...   it's a vital feature were missing here .

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2018 0
Engaged ,
Nov 10, 2018

Copy link to clipboard

Copied

This might be related: Unable to debug on new iPhones

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2018 0