Highlighted

iOS9 Distribution builds fine with no errors but eventbus silently fails?

New Here ,
Dec 07, 2015

Copy link to clipboard

Copied

Hey folks, I am trying to release a version of my app that works perfectly signed as development but when I compile either AdHoc or Distribution builds the ANE's fail to bubble events through FREDispatchStatusEventAsync even though the app builds fine with no reported errors, so this is super difficult to debug! I've never had this issue with iOS 8.x or iOS 7.x either and I've tried recompiling the ANE's using iOS SDK 9.1 and the Beta 9.2 and tried AIR SDK's 18, 19 and 20 beta and have even tried updating the Flex SDK to 4.16.1 but get the same problem every time - Essentially it works in developer mode fine but distribution build offer no joy even though the app builds fine with no reported errors, I'm absolutely stumped on this now and even thinking of ditching AIR for good as it feels so flakey and unloved . . .

Has anyone else experienced this kind of issue for iOS9.x builds if so, how did you resolve it so I can ship my app.

Many thanks in advance.

TOPICS
Performance issues

Views

128

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

iOS9 Distribution builds fine with no errors but eventbus silently fails?

New Here ,
Dec 07, 2015

Copy link to clipboard

Copied

Hey folks, I am trying to release a version of my app that works perfectly signed as development but when I compile either AdHoc or Distribution builds the ANE's fail to bubble events through FREDispatchStatusEventAsync even though the app builds fine with no reported errors, so this is super difficult to debug! I've never had this issue with iOS 8.x or iOS 7.x either and I've tried recompiling the ANE's using iOS SDK 9.1 and the Beta 9.2 and tried AIR SDK's 18, 19 and 20 beta and have even tried updating the Flex SDK to 4.16.1 but get the same problem every time - Essentially it works in developer mode fine but distribution build offer no joy even though the app builds fine with no reported errors, I'm absolutely stumped on this now and even thinking of ditching AIR for good as it feels so flakey and unloved . . .

Has anyone else experienced this kind of issue for iOS9.x builds if so, how did you resolve it so I can ship my app.

Many thanks in advance.

TOPICS
Performance issues

Views

129

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 07, 2015 0

Have something to add?

Join the conversation