Highlighted

It is possible to install my App IN Windows XP, Vista, 8?

Explorer ,
Mar 23, 2019

Copy link to clipboard

Copied

Hi!

I developed an App, but I do not know if it can be installed in Windows XP, Vista, 8:

In the AIR page:

  • Microsoft® Windows Server 2008, Windows 7, Windows 8.1 Classic or Windows 10

Tech specs and system requirements | Adobe AIR

So... my App cannot run in the Windows XP, Vista, 8?

If Yes, what are the requirements for old versions of AIR?

Thanks.

TOPICS
Development

Views

452

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

It is possible to install my App IN Windows XP, Vista, 8?

Explorer ,
Mar 23, 2019

Copy link to clipboard

Copied

Hi!

I developed an App, but I do not know if it can be installed in Windows XP, Vista, 8:

In the AIR page:

  • Microsoft® Windows Server 2008, Windows 7, Windows 8.1 Classic or Windows 10

Tech specs and system requirements | Adobe AIR

So... my App cannot run in the Windows XP, Vista, 8?

If Yes, what are the requirements for old versions of AIR?

Thanks.

TOPICS
Development

Views

453

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 23, 2019 0
Explorer ,
Mar 23, 2019

Copy link to clipboard

Copied

That page you refer to says:

  • Microsoft® Windows Server 2008, Windows 7, Windows 8.1 Classic or Windows 10
  • AIR SDK Development supports Microsoft® Windows 7 and above, 64-bit only

However, I am using AIR SDK 31 and I am generating both a 64-bit Windows app (with the <architecture/> element in the app.xml file) and a 32-bit version, which should run on XP SP3, Vista, 7, and 8 (at least it says the app can when I check the properties, I no longer have a 32-bit system).

-jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 23, 2019 0
Explorer ,
Mar 26, 2019

Copy link to clipboard

Copied

I tested in Windows XP - Vista - 7 - 8 (not 8.1)     [all 32-bits].

XP and Vista not work (error: this is not a valid win32 app).

7 and 8 it is OK.

So, the system requirements should be?:

  • Microsoft® Windows Server 2008, Windows 7, Windows 8, Windows 8.1 Classic or Windows 10

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 26, 2019 0
Explorer ,
Mar 26, 2019

Copy link to clipboard

Copied

Can you right-click on the application and go to Properties, then Compatibility, then check the box -- you should be able to click the dropdown menu and it will have Windows XP, etc. in the list, like this:

Untitled-1.jpg

If the dropdown does not have those OS's, then you have made a 64-bit application. You don't have to run with compatibility (you don't need to check the box for running the app) but you need to check it to get the dropdown.

-jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 26, 2019 0