Locked

Java 8.0_121 and 1024-RSA certificate

Engaged ,
Jan 22, 2017 Jan 22, 2017

Copy link to clipboard

Copied

Hello,

I update java to 8.0_121 on Windows, and I have this messge error on ADT

unable to load a certificate in this file

when I use a 1024-RSA certificate (I don't have this message error with a 2048-RSA certificate)

Thanks.

TOPICS
Performance issues

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 27, 2017 Feb 27, 2017

Copy link to clipboard

Copied

Hello

Can you explain me how to do this? I have the same error.

Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 06, 2017 Mar 06, 2017

Copy link to clipboard

Copied

For Android apps, it's not possible to change the certificates.

Workaround in Windows : change the Java path in the Windows Environment Variables > Path to an older Java version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 04, 2017 Apr 04, 2017

Copy link to clipboard

Copied

How do you change the path for mac?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 05, 2017 Apr 05, 2017

Copy link to clipboard

Copied

Up to Java 1.8.0_74 works fine with RSA-1024 certificates, after upgrade to any higher version, don't work and the described error is shown packaging apps.

The only workaround for now is to downgrade Java.

Adobe, is there a way to Convert RSA-1024 P12 certificates to RSA-2048? because Google demands exactly the same certificate, can't be changed without create a new app in the store.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 19, 2017 Jun 19, 2017

Copy link to clipboard

Copied

Hi,

I got the same issue.

But I try to create a new RSA-1024 certificate(p12) it will run in normally.

So I guess the file format of certificate has been change?

Maybe some content had been removed in the new certificate

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 20, 2017 Jun 20, 2017

Copy link to clipboard

Copied

Unfortunately Animate doesn't allow to create RSA-1024 anymore, the selector combo is grayed out and pre-selected with RSA-2048 certificate, what procedure did you use to create a new RSA-1024 certificate?, it could be useful here to know different procedures to create certificates. Although, the big issue is that if you are updating an existing Android App, a new RSA-1024 certificate doesn't solve anything because that update must be packaged with exactly the same old certificate used to publish the first time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2020 Nov 06, 2020

Copy link to clipboard

Copied

LATEST

I encountered the same issue - see my fix for it in this thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines