Highlighted

Linking process of custom ANE strips too much symbols

Explorer ,
Jan 19, 2015

Copy link to clipboard

Copied

Hello

I'm preparing custom ANE and facing interesting problem. I have prepared static library and putted it to ANE. I have compiled ANE and created demo project. Application is crashing in runtime because of undefined selector.

I have prepare native demo project with totally same library and it works like a charm. So I assume I have all symbols and correct architecture in my static library. I think linking process of ANE in air sdk strips too much symbols from static library and I cannot anyhow influence on it.

I can provide all projects to see the problem.

Any suggestions?

Thanks

TOPICS
Air beta

Views

285

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Linking process of custom ANE strips too much symbols

Explorer ,
Jan 19, 2015

Copy link to clipboard

Copied

Hello

I'm preparing custom ANE and facing interesting problem. I have prepared static library and putted it to ANE. I have compiled ANE and created demo project. Application is crashing in runtime because of undefined selector.

I have prepare native demo project with totally same library and it works like a charm. So I assume I have all symbols and correct architecture in my static library. I think linking process of ANE in air sdk strips too much symbols from static library and I cannot anyhow influence on it.

I can provide all projects to see the problem.

Any suggestions?

Thanks

TOPICS
Air beta

Views

286

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 19, 2015 0

Have something to add?

Join the conversation