Highlighted

MXMLC compiler errors after upgrading from AIR 14 to AIR 23

New Here ,
Sep 10, 2016

Copy link to clipboard

Copied

I'm trying to compile an app against AIR 23, to test hiDPI support on Windows.

My app was previously compiling using a combo SDK of Flex 3.5.0 and AIR 14. (yep, that's an ancient Flex version, but that's all my old app needed)

I cloned my existing SDK folder, and overlaid the new AIR 23 SDk on top of the clone (the same process I've successfully used for previous AIR upgrades)

Now my app fails to compile, complaining about unimplemented methods from the mx.core.IFlexModuleFactory and mx.managers.ISystemManager interfaces.

_cng_mx_managers_SystemManager.as(21): col: 14 Error: Interface method get allowDomainsInNewRSLs in namespace mx.core:IFlexModuleFactory not implemented by class _cng_mx_managers_SystemManager.

_cng_mx_managers_SystemManager.as(21): col: 14 Error: Interface method invalidateParentSizeAndDisplayList in namespace mx.managers:ISystemManager not implemented by class _cng_mx_managers_SystemManager.

That code being referenced (_cng_mx_managers_SystemManager.as) does not exist in my repo. It appears to be something generated on the fly during the compilation process (the "cng" prefix happens to match the <id> property of my app.xml file.

This feels to me like some sort of the library or search path mismatch, or a air-config.xml setting issue.

https://groups.google.com/forum/#!topic/flex-sdk-maven-install/vmLtbCbgUu0​

That post seems to be about a similar issues (compiler problems after a tooling update), but there was no solution posted.

Anyone have ideas?

TOPICS
Development

Views

188

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

MXMLC compiler errors after upgrading from AIR 14 to AIR 23

New Here ,
Sep 10, 2016

Copy link to clipboard

Copied

I'm trying to compile an app against AIR 23, to test hiDPI support on Windows.

My app was previously compiling using a combo SDK of Flex 3.5.0 and AIR 14. (yep, that's an ancient Flex version, but that's all my old app needed)

I cloned my existing SDK folder, and overlaid the new AIR 23 SDk on top of the clone (the same process I've successfully used for previous AIR upgrades)

Now my app fails to compile, complaining about unimplemented methods from the mx.core.IFlexModuleFactory and mx.managers.ISystemManager interfaces.

_cng_mx_managers_SystemManager.as(21): col: 14 Error: Interface method get allowDomainsInNewRSLs in namespace mx.core:IFlexModuleFactory not implemented by class _cng_mx_managers_SystemManager.

_cng_mx_managers_SystemManager.as(21): col: 14 Error: Interface method invalidateParentSizeAndDisplayList in namespace mx.managers:ISystemManager not implemented by class _cng_mx_managers_SystemManager.

That code being referenced (_cng_mx_managers_SystemManager.as) does not exist in my repo. It appears to be something generated on the fly during the compilation process (the "cng" prefix happens to match the <id> property of my app.xml file.

This feels to me like some sort of the library or search path mismatch, or a air-config.xml setting issue.

https://groups.google.com/forum/#!topic/flex-sdk-maven-install/vmLtbCbgUu0​

That post seems to be about a similar issues (compiler problems after a tooling update), but there was no solution posted.

Anyone have ideas?

TOPICS
Development

Views

189

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 10, 2016 0

Have something to add?

Join the conversation