Highlighted

Nape + "-useLegacyAOT no" doesn't work?

Community Beginner ,
Apr 14, 2014

Copy link to clipboard

Copied

I got this error when try to compile:

Error occurred while packaging the application:

0  compile-abc              0x00960428 PrintStackTrace(void*) + 40

1  compile-abc              0x009608a1 SignalHandler(int) + 449

2  libsystem_platform.dylib 0x9a9badeb _sigtramp + 43

3  libsystem_platform.dylib 0xffffffff _sigtramp + 1701073471

4  compile-abc              0x00054173 halfmoon::AbcBuilder::initStmt(unsigned int) + 147

5  compile-abc              0x000581c7 halfmoon::AbcBuilder::visitInstr(unsigned char const*, avmplus::ActionBlockConstants::AbcOpcode, unsigned int, unsigned int, int) + 10055

6  compile-abc              0x00050c3d halfmoon::AbcBuilder::visitBlock(halfmoon::AbcBlock*) + 525

7  compile-abc              0x0005035f halfmoon::AbcBuilder::visitBlocks(nanojit::Seq<halfmoon::AbcBlock*>*) + 63

8  compile-abc              0x000c3656 halfmoon::parseAbc(avmplus::MethodInfo*, halfmoon::Lattice*, halfmoon::InfoManager*, nanojit::Allocator&, halfmoon::AbcGraph*, avmplus::Toplevel*, avmplus::AbcEnv*, halfmoon::ProfiledInformation*, halfmoon::Context&) + 182

9  compile-abc              0x000c4368 halfmoon::JitWriter::writeEpilogue(avmplus::FrameState const*) + 216

10 compile-abc              0x0012c99b avmplus::NullWriter::writeEpilogue(avmplus::FrameState const*) + 27

11 compile-abc              0x00186489 avmplus::Verifier::verify(avmplus::CodeWriter*) + 1273

12 compile-abc              0x0000520f compile_abc::CompilerCore::emitPoolToModule(compile_abc::PoolInfo&, compile_abc::LLVMModule*) + 927

13 compile-abc              0x00004650 compile_abc::CompilerCore::compile() + 5184

14 compile-abc              0x00002f5f compile_abc::CompilerCore::run(int, char**) + 1471

15 compile-abc              0x00005eb2 main + 66

16 compile-abc              0x00001b35 start + 53

Stack dump:

0.          Program arguments: (hidden path) ... /bin-debug/AOT/AOTBuildOutput586108936296049660.tmp/ABCFilesList.txt"

Compilation failed while executing : compile-abc

But if I run without "-useLegacyAOT no" or without Nape, works as expected.

Adobe Community Professional
Correct answer by Colin Holgate | Adobe Community Professional

It’s a known issue, with a fix coming up in a week or two:

http://forums.adobe.com/message/6282358#6282358

TOPICS
Development

Views

217

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Nape + "-useLegacyAOT no" doesn't work?

Community Beginner ,
Apr 14, 2014

Copy link to clipboard

Copied

I got this error when try to compile:

Error occurred while packaging the application:

0  compile-abc              0x00960428 PrintStackTrace(void*) + 40

1  compile-abc              0x009608a1 SignalHandler(int) + 449

2  libsystem_platform.dylib 0x9a9badeb _sigtramp + 43

3  libsystem_platform.dylib 0xffffffff _sigtramp + 1701073471

4  compile-abc              0x00054173 halfmoon::AbcBuilder::initStmt(unsigned int) + 147

5  compile-abc              0x000581c7 halfmoon::AbcBuilder::visitInstr(unsigned char const*, avmplus::ActionBlockConstants::AbcOpcode, unsigned int, unsigned int, int) + 10055

6  compile-abc              0x00050c3d halfmoon::AbcBuilder::visitBlock(halfmoon::AbcBlock*) + 525

7  compile-abc              0x0005035f halfmoon::AbcBuilder::visitBlocks(nanojit::Seq<halfmoon::AbcBlock*>*) + 63

8  compile-abc              0x000c3656 halfmoon::parseAbc(avmplus::MethodInfo*, halfmoon::Lattice*, halfmoon::InfoManager*, nanojit::Allocator&, halfmoon::AbcGraph*, avmplus::Toplevel*, avmplus::AbcEnv*, halfmoon::ProfiledInformation*, halfmoon::Context&) + 182

9  compile-abc              0x000c4368 halfmoon::JitWriter::writeEpilogue(avmplus::FrameState const*) + 216

10 compile-abc              0x0012c99b avmplus::NullWriter::writeEpilogue(avmplus::FrameState const*) + 27

11 compile-abc              0x00186489 avmplus::Verifier::verify(avmplus::CodeWriter*) + 1273

12 compile-abc              0x0000520f compile_abc::CompilerCore::emitPoolToModule(compile_abc::PoolInfo&, compile_abc::LLVMModule*) + 927

13 compile-abc              0x00004650 compile_abc::CompilerCore::compile() + 5184

14 compile-abc              0x00002f5f compile_abc::CompilerCore::run(int, char**) + 1471

15 compile-abc              0x00005eb2 main + 66

16 compile-abc              0x00001b35 start + 53

Stack dump:

0.          Program arguments: (hidden path) ... /bin-debug/AOT/AOTBuildOutput586108936296049660.tmp/ABCFilesList.txt"

Compilation failed while executing : compile-abc

But if I run without "-useLegacyAOT no" or without Nape, works as expected.

Adobe Community Professional
Correct answer by Colin Holgate | Adobe Community Professional

It’s a known issue, with a fix coming up in a week or two:

http://forums.adobe.com/message/6282358#6282358

TOPICS
Development

Views

218

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 14, 2014 0
Adobe Community Professional ,
Apr 14, 2014

Copy link to clipboard

Copied

It’s a known issue, with a fix coming up in a week or two:

http://forums.adobe.com/message/6282358#6282358

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2014 0
Community Beginner ,
Apr 14, 2014

Copy link to clipboard

Copied

Thank you, Colin!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2014 0