Highlighted

PNGs from older FLA's don't compile in Air

Participant ,
Jan 29, 2015

Copy link to clipboard

Copied

I have some older Air apps I'm updating and I'm getting a graphic bug. How my process works is I create a graphical asset ( image, button, animation or control skin ) in Flash CC, assign it a class name and publish a SWC. I then use the SWC as a graphical asset library in Flash Builder.

I've noticed recently that PNG's from my older projects display fine in Flash CC but when I compile the app the image data is transparent in the app. This is only PNG's not JPG's.

I also have the same issue with a modern Air app created only 7 months ago when I migrate from Mac to PC or back and forth ( I develop on both OS' ). I have to export the image and then re-import it. Again the image appears fine in Flash CC, it's only when I compile it into the App that the bitmap data seems to go transparent.

Running Flash CC and Air 15.

Hi Pete,


check the compression you have selected for the PNGs (in Flash CC Library -> right click the PNG -> properties). If you selected "Photo (JPEG)" compression then the PNGs are not displayed. Select "Lossless (PNG/GIF)" and export the SWC again.

Hope this helps.

Best regards

Wolfgang

TOPICS
Performance issues

Views

295

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PNGs from older FLA's don't compile in Air

Participant ,
Jan 29, 2015

Copy link to clipboard

Copied

I have some older Air apps I'm updating and I'm getting a graphic bug. How my process works is I create a graphical asset ( image, button, animation or control skin ) in Flash CC, assign it a class name and publish a SWC. I then use the SWC as a graphical asset library in Flash Builder.

I've noticed recently that PNG's from my older projects display fine in Flash CC but when I compile the app the image data is transparent in the app. This is only PNG's not JPG's.

I also have the same issue with a modern Air app created only 7 months ago when I migrate from Mac to PC or back and forth ( I develop on both OS' ). I have to export the image and then re-import it. Again the image appears fine in Flash CC, it's only when I compile it into the App that the bitmap data seems to go transparent.

Running Flash CC and Air 15.

Hi Pete,


check the compression you have selected for the PNGs (in Flash CC Library -> right click the PNG -> properties). If you selected "Photo (JPEG)" compression then the PNGs are not displayed. Select "Lossless (PNG/GIF)" and export the SWC again.

Hope this helps.

Best regards

Wolfgang

TOPICS
Performance issues

Views

296

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 29, 2015 0
Adobe Employee ,
Jan 29, 2015

Copy link to clipboard

Copied

Hi Pete,

I'm asking the Flash CC team if they have any guidance for you.  I haven't heard of this occurring before.

Thanks,

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2015 0
Adobe Employee ,
Jan 30, 2015

Copy link to clipboard

Copied

hi Pete,

Can you please share the test content and detailed steps which helps to reproduce this issue.

Rgds,

Mukesh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2015 0
Participant ,
Feb 02, 2015

Copy link to clipboard

Copied

Mukesh, I'll try to put something together for you in a day or two.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2015 0
Adobe Employee ,
Feb 02, 2015

Copy link to clipboard

Copied

Thanks Pete. Will wait for the content and detailed steps to reproduce this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2015 0
Explorer ,
Jan 30, 2015

Copy link to clipboard

Copied

Hi Pete,


check the compression you have selected for the PNGs (in Flash CC Library -> right click the PNG -> properties). If you selected "Photo (JPEG)" compression then the PNGs are not displayed. Select "Lossless (PNG/GIF)" and export the SWC again.

Hope this helps.

Best regards

Wolfgang

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2015 0
Participant ,
Feb 02, 2015

Copy link to clipboard

Copied

Ya tried that first thing. It didn't have any effect.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2015 0
Participant ,
Feb 03, 2015

Copy link to clipboard

Copied

So I tried changing the photo format in Flash CC in Air 15 and it didn't work but when I updated to Air 16 that did work... not sure why.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2015 0