Highlighted

Problem with mask in mask with GPU mode on HTC One m8

New Here ,
Jan 08, 2015

Copy link to clipboard

Copied

Hi, this could be an old bug, we're seeing a problem with AIR 15 and 16 on only this particular newish HTC Android (4.2.2) phone. Our app uses GPU renderMode. The problem happens if you have a masked MovieClip with children that have children that are also masked, then only the first masked child renders. All other non-masked objects also render, but if any one of them has a mask, then that one will not render. This problem does not happen on an older HTC One X and HTC Desire 610 running the same Android version (4.2.2). It also does not happen on iOS or Google Nexus 4.

Thanks for your help!

Hi,

There is a workaround for this issue.  If we set cacheAsBitmap (this.cacheAsBitmap=true;) property of the masked children to true , then all the masked children will render in the gpu mode properly.

Attaching the same sample app with respective modification to resolve  the issue in Bug#3921039 - Problem with mask in mask with GPU mode on HTC One m8 . Requesting you to please publish the app with the method mentioned on your device for which this issue was occurring.

Note:

The following documentation about gpu render mode - http://help.adobe.com/en_US/as3/mobile/WS901d38e593cd1bac-3d719af412b2b394529-8000.html states that : "GPU rendering is more restrictive in mobile AIR apps created with the Packager for iPhone. The GPU is only effective for bitmaps, solid shapes, and display objects that have the cacheAsBitmap property set. "

Please let us know in case you still face any issues.

regards,

Adobe AIR Team

TOPICS
Performance issues

Views

818

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problem with mask in mask with GPU mode on HTC One m8

New Here ,
Jan 08, 2015

Copy link to clipboard

Copied

Hi, this could be an old bug, we're seeing a problem with AIR 15 and 16 on only this particular newish HTC Android (4.2.2) phone. Our app uses GPU renderMode. The problem happens if you have a masked MovieClip with children that have children that are also masked, then only the first masked child renders. All other non-masked objects also render, but if any one of them has a mask, then that one will not render. This problem does not happen on an older HTC One X and HTC Desire 610 running the same Android version (4.2.2). It also does not happen on iOS or Google Nexus 4.

Thanks for your help!

Hi,

There is a workaround for this issue.  If we set cacheAsBitmap (this.cacheAsBitmap=true;) property of the masked children to true , then all the masked children will render in the gpu mode properly.

Attaching the same sample app with respective modification to resolve  the issue in Bug#3921039 - Problem with mask in mask with GPU mode on HTC One m8 . Requesting you to please publish the app with the method mentioned on your device for which this issue was occurring.

Note:

The following documentation about gpu render mode - http://help.adobe.com/en_US/as3/mobile/WS901d38e593cd1bac-3d719af412b2b394529-8000.html states that : "GPU rendering is more restrictive in mobile AIR apps created with the Packager for iPhone. The GPU is only effective for bitmaps, solid shapes, and display objects that have the cacheAsBitmap property set. "

Please let us know in case you still face any issues.

regards,

Adobe AIR Team

TOPICS
Performance issues

Views

819

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 08, 2015 0
Adobe Employee ,
Jan 09, 2015

Copy link to clipboard

Copied

Would you mind opening a new report on this over at http://bugbase.adobe.com?  If you can attach a small sample project, I'll ask our QE to take a look and see if this is a known issue.  Do you know if 4.2.2 is the latest release for the M8?  I've got a couple of these phones but I'm running 4.4.4.

Thanks,

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2015 0
New Here ,
Jan 13, 2015

Copy link to clipboard

Copied

I believe AT&T rolled back the M8 to 4.2.2 because of some issues that users were experiencing, but 4.4.4 should be released soon. I could be wrong.  But I have other android phones running 4.2.2 that don't exhibit this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 13, 2015 0
Adobe Employee ,
Jan 13, 2015

Copy link to clipboard

Copied

Gotcha.  Do you have a bug number I can reference to the team?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 13, 2015 0
New Here ,
Jan 14, 2015

Copy link to clipboard

Copied

I have posted a bug here:  Bug#3921039 - Problem with mask in mask with GPU mode on HTC One m8

The bug includes a small sample app (FLA+SWF+packaging script) that demonstrates this problem.

Thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2015 0
Adobe Employee ,
Jan 15, 2015

Copy link to clipboard

Copied

We've been able to reproduce this and will work to figure out what's going on.  Thanks for the heads up!  For reference, our internal bug number is 3921441.

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 15, 2015 0
New Here ,
Feb 06, 2015

Copy link to clipboard

Copied

I can confirm that this problem also happens on HTC One VX devices. Masking on these devices also seems to fail when the mask object and the Bitmap instance that its masking have cacheAsBitmap=true and cacheAsBitmapMatrix set. This works fine on iOS and Nexus devices.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2015 0
Adobe Employee ,
Feb 06, 2015

Copy link to clipboard

Copied

We're still working on it.  Currently trying to track down the exact build that this behavior started occurring in.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 06, 2015 0
Adobe Employee ,
Feb 09, 2015

Copy link to clipboard

Copied

Hi,

Thanks for providing all the data for investigation, requesting you to please also provide action script code for the issue encountered.

regards,

Adobe AIR Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 09, 2015 0
New Here ,
Feb 09, 2015

Copy link to clipboard

Copied

I did, see the post above from Jan 14:

I have posted a bug here:  Bug#3921039 - Problem with mask in mask with GPU mode on HTC One m8

The bug includes a small sample app (FLA+SWF+packaging script) that demonstrates this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 09, 2015 0
Adobe Employee ,
Feb 12, 2015

Copy link to clipboard

Copied

Hi,

There is a workaround for this issue.  If we set cacheAsBitmap (this.cacheAsBitmap=true;) property of the masked children to true , then all the masked children will render in the gpu mode properly.

Attaching the same sample app with respective modification to resolve  the issue in Bug#3921039 - Problem with mask in mask with GPU mode on HTC One m8 . Requesting you to please publish the app with the method mentioned on your device for which this issue was occurring.

Note:

The following documentation about gpu render mode - http://help.adobe.com/en_US/as3/mobile/WS901d38e593cd1bac-3d719af412b2b394529-8000.html states that : "GPU rendering is more restrictive in mobile AIR apps created with the Packager for iPhone. The GPU is only effective for bitmaps, solid shapes, and display objects that have the cacheAsBitmap property set. "

Please let us know in case you still face any issues.

regards,

Adobe AIR Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 12, 2015 0
Toxikman LATEST
New Here ,
Feb 25, 2015

Copy link to clipboard

Copied

Hi, thanks for the work-around. However, this work-around works in the case of static objects, but still does not fix the issue when animations are inside the mask because cacheAsBitmap is very costly and expensive on mobile devices when the masked child object is changing.

Also is there a way to reliably check the device model number or Android version from within flash in order to conditionally know when this bug might happen? In other words, perhaps you know what operating system conditions will cause this bug to happen?

Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2015 0