Highlighted

StageWebView and Google Maps JS API: Object.freeze error

Community Beginner ,
May 13, 2019

Copy link to clipboard

Copied

I am getting this error when I try to load a page containing the Google Maps JS API through StageWebView:

TypeError: Result of expression 'Object.freeze' [undefined] is not a function.

It used to work several months ago, but now it seems to be broken. Apparently because StageWebView does not support some of the latest webkit stuff or whatever.

One solution I found was to use webView = new StageWebView(true); to use the native browser. But this time the map doesn't load at all (although I don't get an Object.freeze error this time).

Has anyone here encountered a similar problem and found a solution?

TOPICS
Development

Views

527

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

StageWebView and Google Maps JS API: Object.freeze error

Community Beginner ,
May 13, 2019

Copy link to clipboard

Copied

I am getting this error when I try to load a page containing the Google Maps JS API through StageWebView:

TypeError: Result of expression 'Object.freeze' [undefined] is not a function.

It used to work several months ago, but now it seems to be broken. Apparently because StageWebView does not support some of the latest webkit stuff or whatever.

One solution I found was to use webView = new StageWebView(true); to use the native browser. But this time the map doesn't load at all (although I don't get an Object.freeze error this time).

Has anyone here encountered a similar problem and found a solution?

TOPICS
Development

Views

528

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 13, 2019 0
Community Beginner ,
May 13, 2019

Copy link to clipboard

Copied

Further information:

It seems that the problem stems from the fact that the in-built StageWebView browser uses an old version of WebKit (533.19.4 at the moment, while the latest is 537.36). Presumably the google maps API uses something that is not supported by the old version.

Of course when it is told to use the native browser, it uses IE6 which has no WebKit support whatsoever.

On mobiles, the system browser it uses is thankfully up to date, so no problems there. But on windows machines, the fact it uses an outdated WebKit, and uses IE6 as a fallback, makes it incompatible.

It needs to be updated to work with the *actual* default browser.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 0
Community Beginner ,
May 13, 2019

Copy link to clipboard

Copied

My GOD, I just read that the WebKit Adobe uses has not been updated since 2010!

There is even a ticket in the tracker dating back to 2013, asking for it to be updated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 0
Contributor ,
May 13, 2019

Copy link to clipboard

Copied

You can vote for my ticket from 2013 if ya want.

if they did this, they could skip the 'video improvements' and we could just play video the browser.


Google maps API 3.34 is the last version that will work in Desktop AIR.    3.35 is releasing tomorrow.

I've rewritten all my maps utilizing BING static maps and then 'sniffing' for the AIR browser.  Tomorrow, my AIR desktop users will get a different map than iOS ( Thev've updated that browser due to an Apple requirement )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 1
Community Beginner ,
May 13, 2019

Copy link to clipboard

Copied

Yeah I've voted for it. Not holding my breath though.

I've tried using the older JS API using ?v=3.34 (or even ?v=3.30) but it didn't seem to have any effect. I guess that's not really an option?

I think I'll have to purchase and use a NativeMaps ANE. I'm not having particularly warm feelings about the prospect of my apps breaking because of google API updates in the near future.

Problems like this make me so glad I've switched away from AIR, but I still have existing projects that need support, and I dread the day I'll have to tell clients "sorry, your app won't run anymore because adobe stopped supporting this feature 5 years ago and I have run out of possible workarounds that were keeping it working."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 0
Contributor ,
May 13, 2019

Copy link to clipboard

Copied

Per the google API.  about three years ago they stopped supporting all the flavors of 'old versions' and when with this model of 'four qaurters' trailing.

In your application you can specify release channels or version numbers:

  • The weekly channel is specified with v=weekly.
    This channel is updated once per week, and is the most current.
  • The quarterly channel is specified with v=quarterly.
    This channel is updated once per quarter, and is the most predictable.
  • The version number is specified with v=n.nn.
    You can choose v=3.36, v=3.35, or v=3.34.
    Version numbers are updated once per quarter (see Quarterly updates).

If you do not explicitly specify a channel or version, you will receive the weekly channel by default. If you're on the premium plan and do not explicitly specify a channel or version, you will receive the quarterly channel by default. If you specify an invalid version, you will receive your default channel.

I've been trying to get off AIR for years, but the purse string holders have had a 'it's still working' attitude.  I seems my craftiness in workarounds has created this issue where we'll be running straight into a wall full speed.

I believe the iOS should continue to work.  Testing that now

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 1
Contributor ,
May 13, 2019

Copy link to clipboard

Copied

Compiled AIR 31.0 on iOS 12 shows : AppleWebKit/605.1.15  ( which is the most recent )

Desktop Window 10 is reporting : Mozilla/5.0 (Windows; U; en-US) AppleWebKit/533.19.4 (KHTML, like Gecko) AdobeAIR/31.0

via .php script

<?  echo $_SERVER['HTTP_USER_AGENT']

WebKit/534.57.2  ( safari 5.1.7 ) was the last webkit officially released on the windows platform.

We REALLY need a modern browser in AIR.  It would save the day. I would just make an AIR app that's a container for web content...hahaha



Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 1
Enthusiast ,
May 13, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 0
Contributor ,
May 13, 2019

Copy link to clipboard

Copied

Thanks I'll give this a look...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 0
Contributor ,
May 13, 2019

Copy link to clipboard

Copied

The shims don't stop Google Maps API from flagging it as an obsolete browser. 
There are other rendering issues, like the icons on the controls and so much more.

Thanks for the shim pack though.  I'm sure I'll find a use for it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 13, 2019 0