Highlighted

StageWebView on Windows Desktop Problem

New Here ,
Oct 20, 2016

Copy link to clipboard

Copied

Hi,

I am using the StageWebView(true) method to create a browser window in Adobe Air for Win Desktop latest version. Everything looks great on my machine, but when my customer uses the app, the website is rendered using IE compatibility view. Is there any way to force StageWebView NOT to use the compatibility view? Or is there any way to tell Windows to disable this modus? I already switched off all options under "Tools/ Compatibility View Settings" in IE with no effect.

I would really appreaciate your help!

Thank you very much
Tobias

TOPICS
Development

Views

753

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

StageWebView on Windows Desktop Problem

New Here ,
Oct 20, 2016

Copy link to clipboard

Copied

Hi,

I am using the StageWebView(true) method to create a browser window in Adobe Air for Win Desktop latest version. Everything looks great on my machine, but when my customer uses the app, the website is rendered using IE compatibility view. Is there any way to force StageWebView NOT to use the compatibility view? Or is there any way to tell Windows to disable this modus? I already switched off all options under "Tools/ Compatibility View Settings" in IE with no effect.

I would really appreaciate your help!

Thank you very much
Tobias

TOPICS
Development

Views

754

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 20, 2016 0
Adobe Community Professional ,
Oct 20, 2016

Copy link to clipboard

Copied

One of the parameters of StageWebView is whether the system's native browser is used. Try StageWebView(false), that will make it use an embedded browser, that may not perform as well as the native one, but should look the same for your users.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2016 0
New Here ,
Oct 20, 2016

Copy link to clipboard

Copied

Thanks for your help Colin, sadly with the use of the embedded browser the website does not work correctly. The native browser is the way to go, if only there is a way to turn off compatibility view...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2016 0
Engaged ,
Oct 20, 2016

Copy link to clipboard

Copied

Have you tried adding the following block of HTML to the <head> section of your web pages?

<meta http-equiv="x-ua-compatible" content="IE=edge">

That tells IE to use the best/newest rendering mode available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2016 0
New Here ,
Oct 20, 2016

Copy link to clipboard

Copied

Hello wadedwalker, thank you for that snippet, sadly the website is not in my control - no chance to add something to it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2016 0
New Here ,
Oct 21, 2016

Copy link to clipboard

Copied

Some more information: Its a problem that occurs with Windows 10. In Windows 7 (my computer) it works fine - Windows 10 renders StageWebView(true) in compatibility view....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 21, 2016 0
heilong LATEST
Community Beginner ,
Sep 23, 2017

Copy link to clipboard

Copied

Hi. Did you find a way to resolve this problem?

I'm having the same issue - works fine on Win7 (User agent is reported as Mozilla/5.0 Trident/7.0 rv:11.0), but on Win10 it's using compatibility mode (User agent is reported as Mozilla/4.0 Trident/7.0), and certain features are not available (e.g. window.addEventListener, JSON.stringify), breaking the JS code that should run in that StageWebView.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2017 0