Highlighted

Trouble installing .air app on mac

Explorer ,
Mar 02, 2015

Copy link to clipboard

Copied

Screenshot 2015-03-02 16.52.18.jpg

For the sake of people searching, or if the image gets removed on day, here is the error message as text:

"Sorry, an error has occured.  The application cannot be installed due to a certificate problem.  The certificate does not match the installed application certificate, does not support application upgrades, or is invalid.  Please contact the application author."

I keep getting the above error when trying to install a new .air desktop file on a third-party Mac over which I have limited control.  The .air app does work on Windows 8.1.

-Do you think it could be the AIR runtime (currently version 14, and am getting admin to update it to version 16)?  I built the app in AIR 16.

-There is a previous version of the app, with a different certificate that is already installed.  Would this possibly cause the error?

-Finally, I signed the app with a self-created certificate for development reasons.  Is that likely to be a problem, it didn't seem to be an issue last time I did this?

Thank you.

TOPICS
Installation

Views

276

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Trouble installing .air app on mac

Explorer ,
Mar 02, 2015

Copy link to clipboard

Copied

Screenshot 2015-03-02 16.52.18.jpg

For the sake of people searching, or if the image gets removed on day, here is the error message as text:

"Sorry, an error has occured.  The application cannot be installed due to a certificate problem.  The certificate does not match the installed application certificate, does not support application upgrades, or is invalid.  Please contact the application author."

I keep getting the above error when trying to install a new .air desktop file on a third-party Mac over which I have limited control.  The .air app does work on Windows 8.1.

-Do you think it could be the AIR runtime (currently version 14, and am getting admin to update it to version 16)?  I built the app in AIR 16.

-There is a previous version of the app, with a different certificate that is already installed.  Would this possibly cause the error?

-Finally, I signed the app with a self-created certificate for development reasons.  Is that likely to be a problem, it didn't seem to be an issue last time I did this?

Thank you.

TOPICS
Installation

Views

277

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 02, 2015 0

Have something to add?

Join the conversation