Highlighted

win,air sdk 22,versionCode bad

New Here ,
Apr 08, 2016

Copy link to clipboard

Copied

WINDOWS,AIR SDK 22 FOR APK;

When I update to the latest version of the SDK, android version, it reads the version number, an error occurs!

app.xml   : <versionNumber>10.1.2</versionNumber>


But read versionCode value is :  10001002

TOPICS
Air beta

Views

522

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

win,air sdk 22,versionCode bad

New Here ,
Apr 08, 2016

Copy link to clipboard

Copied

WINDOWS,AIR SDK 22 FOR APK;

When I update to the latest version of the SDK, android version, it reads the version number, an error occurs!

app.xml   : <versionNumber>10.1.2</versionNumber>


But read versionCode value is :  10001002

TOPICS
Air beta

Views

523

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 08, 2016 0
Adobe Employee ,
Apr 10, 2016

Copy link to clipboard

Copied

Hi,

In case of Android <versionNumber> maps to versionCode and this is used to check if update is available or not.

While <versionLabel> maps to versionName and is only for representation purpose to show to the users.

If <versionLabel> is not provided then <versionNumber> is used for both versionCode and versionName.

For this case if <versionName> is 10.1.2 and <versionLabel> is not provided the values should be

versionCode - 10001002

versionName - 10.1.2

This can be verified by below command

aapt dump badging <yourapkname.apk>

Hope this Helps!

Thanks,

Krati

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2016 0
New Here ,
Apr 10, 2016

Copy link to clipboard

Copied

SDK22 There really is wrong.  Previous versions of right,

QQ图片20160411134143.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2016 0
Adobe Employee ,
Apr 10, 2016

Copy link to clipboard

Copied

Could you please confirm what is the versionCode value when you package your application with a previous version of AIR SDK?

Thanks,

Krati

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2016 0
New Here ,
Apr 10, 2016

Copy link to clipboard

Copied

Not very sure.

ANE before read the version comparison, normal. Update to 22, found that failure, found out the problem.

However, just to test the old SDK is also found this problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2016 0
krati LATEST
Adobe Employee ,
Apr 10, 2016

Copy link to clipboard

Copied

It would be great if you can share a sample project so that we can get a better understanding of the problem. You can send your files to krgupta AT adobe DOT com.

Thanks,

Krati

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2016 0