Locked

XCode 5.1 updated and now I can't debug AIR apps on iOS Simulator anymore

New Here ,
Mar 11, 2014 Mar 11, 2014

Copy link to clipboard

Copied

Today XCode updated itself to version 5.1, with new iOS 7.1 platform support. It updated itself without asking permission, and now I can't run my AIR apps on the iOS simulator anymore. All my apps fail with the following error:

'Launching [myApplication]' has encountered a problem.

Error occurred while installing the application:

dyld: Library not loaded: @rpath/iPhoneSimulatorRemoteClient.framework/Versions/A/iPhoneSimulatorRemoteClient

  Referenced from: /Applications/AIR_SDKS/AIRSDK_4.0.0.1628/lib/aot/bin/isb/isb

  Reason: image not found

/var/folders/g1/014r026919j9fkv085ypt31r0000gn/T/cmd7720052456329253213.tmp: line 1:  2126 Trace/BPT trap: 5       "/Applications/AIR_SDKS/AIRSDK_4.0.0.1628/lib/aot/bin/isb/isb" "-install" "-apppath" "/var/folders/g1/014r026919j9fkv085ypt31r0000gn/T/eb03981d-5689-4bb5-821c-78ca84086393/Payload/[myApplication].app" "-sdkpath" "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk"

I use AIR SDK 4.0.1628 (the latest version according to the SDK download page today), and it doesn't make a difference if I choose another simulator version (7.0 and 6.1 fail the same way).

I'm developing in Flash Builder 4.7, on OS X 10.9.2

Any ideas of how to fix this? Will using the AIR 13 beta help?

Thanks, Frank

TOPICS
Development

Views

17.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 12, 2014 Mar 12, 2014

Copy link to clipboard

Copied

Hi Frank,

Issue is reproducible at our end as well and we are investigating it.

Thanks,

Nimisha

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2014 Mar 12, 2014

Copy link to clipboard

Copied

We are having the same issue.

Things I have tried to do to fix this:  Re-installed XCode and redownloaded the simulators, updated iTunes.  This did not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 13, 2014 Mar 13, 2014

Copy link to clipboard

Copied

So, is there a bug filed for this? If so can you share the link so those of us who are interested can follow it.

I can confirm removing Xcode 5.1 and installing 5.0.x fixed the problem for now.

Thanks,

Jason

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2014 Mar 16, 2014

Copy link to clipboard

Copied

Has any progress been made on this? I have the same problem. (http://forums.adobe.com/thread/1428120) Can we expect an update to AIR SDK or even a work around in the mean time?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 19, 2014 Mar 19, 2014

Copy link to clipboard

Copied

Getting the same issue. Just created a new app to confirm.

Error occurred while installing the application:

dyld: Library not loaded: @rpath/iPhoneSimulatorRemoteClient.framework/Versions/A/iPhoneSimulatorRemoteClient

  Referenced from: /Applications/Adobe Flash Builder 4.7/sdks/4.12.0/lib/aot/bin/isb/isb

  Reason: image not found

/var/folders/fb/12wzy6754c7f0ssgt_n049g00000gn/T/cmd4233772018768529484.tmp: line 1:  2265 Trace/BPT trap: 5       "/Applications/Adobe Flash Builder 4.7/sdks/4.12.0/lib/aot/bin/isb/isb" "-install" "-apppath" "/var/folders/fb/12wzy6754c7f0ssgt_n049g00000gn/T/4510bbcb-462d-46ad-9bf8-bb6904b37434/Payload/TestSimulator.app" "-sdkpath" "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.0.sdk"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 19, 2014 Mar 19, 2014

Copy link to clipboard

Copied

Please let us know when a fix is available.  Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 22, 2014 Mar 22, 2014

Copy link to clipboard

Copied

Yep. I wasted a few hours on this one too this morning.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 22, 2014 Mar 22, 2014

Copy link to clipboard

Copied

JamieCrow,

Maybe we should introduce Adobe to the Apple Developer Program, where Apple post several beta versions of Xcode before it is released, and lets you talk to their engineers?  That way, since Adobe product functionality depends on staying current with Apple technology, the two firms can communicate, and Adobe can ready their products for compatibility before users run into roadblocks?

busitech

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 22, 2014 Mar 22, 2014

Copy link to clipboard

Copied

Apple does this on purpose, its thier policy to obfuscate their technology. Its Apples' way or not at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

Does anyone know if we are any nearer to a fix??

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

Who wants to be the guinea pig?

I'm skeptical because the open items on that list seem to conflict with the fixed one.

Report back if this actually works now.

Thanks,

Jason

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

yes. works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

Guy's can anyone throw me a frikkin' bone please.

How would one go about installing this? I'm new to this IDE and have been throwing in the deep end picking up where someone else left off. I'm finding the conflicting instructions and naming scheme just bizarre and infuriating.

I've done the overlaying thing to bring me up to AIR 4 so I can still export an IPA itunes will accept but what's the deal with AIR 3.x to 4 and how does AIR 13 beta fit in?

To be frank I find the overlay think with SDK's in a program at v 4.7 that I have to pay serious cash for insulting and absurd. I mean seriously come on, it's the sort of thing I might expect in an open source app but not in a commercial product.

I'm not developing when I'm wresting against an abortion of an IDE so any pointers would be much appreciated!

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

It wont even let me choose the option to use the iOS simulator when I switched to AIR 13

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

Antony,

Sure, it's really not that difficult. The air 13 thing is a jump to bring parity to the flash player and air versions so the next version will be 13.

Do yourself a favor and go to http://flex.apache.org and download the apache flex installer for developers. That will automate the whole download and overlay process. Then you just have an sdk folder to point the IDE to in the compiler/sdk settings.

Then you should be good to go.

-Jason

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

I am using Flash CC, downloaded the AIR 13 SDK Compiler Beta (NOT Flex) and added the SDK using the HELP menu.

If I use AIR 4.0 it will fail to install the app on the iOS Simulator

If I use AIR 13 Beta, it doesn't even give me the option to use the iOS Simulator (the option is disabled)

This is on a Mac with 10.9 and most recent verson of Flash CC and Xcode 5.1 and iOS 7.1

Please EXPLAIN how/what you did to fix the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

Thanks for the steer Jason that worked,

So that would be Apache Flex 4.12 using Flex installer 2.7 will bring the same benefits of AIR SDK for Flex 13...... I basically have to use an installer from a third party to make the commercial product I pay for work to solve the precise problem its sold as solving.

It's like buying a friggin' drill you have to put together yourself.

I'm gonna get this build finished, then sneak into Flash Builders room while it's having a sleep after a big dinner and smother it with a pillow. It's the kindest thing to do. Ha!

@DavidDragon,

Follow these steps:

http://flex.apache.org/doc-getstarted.html

However just make sure you use the latest version [4.12.0]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

I told you I use Flash CC, NOT Flash builder and Flex...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

Oh right, I'm afraid I've never used that so can't offer much guidance.

Surely there must be a tutorial which shows you how to select or manage the SDK which Flash CC uses. The installation of Flex and AIR via the Apache installer will be the same, it's just how you point Flash CC to it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

I just download the SDK and then use the Manage Extentions menu option in Flash CC to add the SDK then select which SDK i use in the project. It hasn't been working though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

I see the same issue, and have been waiting for AIR to claim to have fixed the issue. Now that it claims that it works I will ask the Flash pro team why it is that the menu item is still grayed out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2014 Apr 29, 2014

Copy link to clipboard

Copied

To install the new (or any future SDK), first download the SDK & Compiler. For Air 13 Beta, go here and download the SDK& Complier Beta (make sure its this one!): http://labs.adobe.com/downloads/air.html

Then, follow these steps to install it: http://helpx.adobe.com/flash-builder/kb/overlay-air-sdk-flash-builder.html

Then close and relaunch flash builder.

Yes, it's kind of a pain, but should really take < 10 minutes. Doing this allowed me to launch the iOS simulator again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 30, 2014 Apr 30, 2014

Copy link to clipboard

Copied

I've already said that I use Flash CC, not flash builder. When will this issue be addressed? Also, when testing use the AIR Simulator (mobile), AIR 13 iis laggy while AIR 4 is not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines