Adobe Animate character rig keeps breaking

Community Beginner ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

I'm running into a huge issue with Adobe Animate. I'm trying to pose my character, which is rigged with parent layering, with the keyframes I want it set on the timeline. But when I go back, it randomly breaks like the example below, this has never happened to me before and I didn't do anything out of the ordinary. I've gone back to make corrections, but it keeps breaking and I don't know what's going on. Can somebody help me out please? Otherwise, Adobe Animate will become unusable.David Poses Messup.png

TOPICS
Error , Other , Performance , Product issue , Timeline

Views

233

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

You may want to up your game and explore SMR.

 

 

[video]

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Ok I'll check these videos out. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Are you using Auto Keyframe ON. If Yes it is a known issue and we have fixed it internally. Fix will be soon available in upcoming release. You can avoid these issue if you Disable Autokeyframe.

 

If it still exists please share a short screen recording of the issue with us to investigate on the same. 

 

Thanks!

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Okay, sure.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

If the Auto Keyframe ON is that buggy, than I jus twon't use it and just keyframe each part until the patch arrives to fix it. I'll try that and update you as to how it went.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

*just won't use it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Also worth mentioning I have experienced this if I update any parent/child relationships across keyframes - it will break the rig. In other words, if the arm is parented to the torso in keyframe A but then I change it in keyframe B, it breaks. Scrub your timeline and watch the layer parenting window to see if anything changes across keyframes.


Animator and content creator for Animate CC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

All the parent/child relationships are fine, I don't see any anomalies anywhere else.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2022 Jan 08, 2022

Copy link to clipboard

Copied

Did you accidentally change the center point for a symbol(s) instance on any keyframes?


Animator and content creator for Animate CC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2022 Jan 08, 2022

Copy link to clipboard

Copied

No I didn't. I have the center points where I want them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Show us a screen shot of your layer parent set up. so we can see if there is an issue with it. 


Multimedia Developer, Character Creator, and Animator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

LATEST

Okay, here. And the relationships don't change at all when I scroll through the timeline. I just tried posing without the auto keyframe and it seems to work much better. So I really do think it's the Auto Keyframe that's the problem just like Arvind said.

Parent Child layer.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines