• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

AnimateCC 2021.01 Canvas BUG: Edit Frame Label Name = Frame Label Disappears?

Engaged ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Get a load of this:


 

Anyone else having this issue? How do you get it to stop?

Since I can't link to the video placed on my own server (...which would be a Valid Video URL), I had to put it on YouTube for the whole world to see. 

TOPICS
Error , Product issue , Timeline

Views

615

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

I just tried to repro this and couldn't. What version of AnCC are you running? OS X or Win? What kind of AnCC document are you creating?


Animator and content creator for Animate CC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

v2021.01, Canvas Win10.

Since I create frame labels in serial DS1A, DS1B, DS1C etc... I copy and paste a frame that contains the label DS1, then add the A, B, C, etc... it beats typing them out for every frame I want labeled; it's quicker. 

Or, so I thought. 

Thanks. 




Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

I tried to repro using a Canvas doc and couldn't - but I'm on Mac at the moment - I can test on Win but not for a couple days. One suggestion; Type out your frame label in the first blank keyframe in a new layer dedicated to frame labels only, hold down option and drag this keyframe to a new frame. It should duplicate the frame label - now try and edit the label name.


Animator and content creator for Animate CC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

It happens to me after copy+pasting a frame with a label also, it's very annoying. On the latest animate + windows 10. Document is an adobe air fla. (desktop / android)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

I also confirm that the frame label text disappears when attempting to edit it, but only after copying and pasting multiple frames as I've shown in the below video:

https://youtu.be/AYUjhNSPkq4

 

Video Tested With:

  • Adobe Animate Version - 24.0 Build 305
  • Blank Actionscript 3.0 document


As a workaround, a script could be used to edit label text with a pop-up window, but I believe most users would prefer not to use such a workaround, and not to retype any lost text.   

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

I was not able to repo your issue either. maybe upgrade to Animate 24 there have been a lot of bugs fixed. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Unfortunately, I found it is still an issue with Adobe Animate Version - 24.0 Build 305 and it seems to have been present since Adobe Animate 2021 as I demonstrate in the below video where I reproduce the bug in different versions of Adobe Animate. However, the issue is not present in Adobe Animate 2018 which leads me to believe this bug was introduced when the UI changed in 2020.

 

https://youtu.be/3lhZ8hHWVXA

 

Did you follow the same reproduction steps from this video @Nicktendo28 ?
Adobe Animate Bug - Frame Label Text Disappears When Editing - YouTube

In short, the steps I used to reproduce the bug are:


1. Create multiple keyframes and add text to the Frame Label Name field in the properties panel. 

 

2. Create another layer so that you have more frames to copy later for testing purposes. 

 

3. Select multiple frames across multiple layers and make sure to include at least one frame that has a frame label name assigned to it.

 

4. Copy the frames and paste them further down the timeline within the same layers using the "Paste and Overwrite frames" command. 

 

5. Proceed to attempt to edit the frame label name of any frame containing one and the text will disappear. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

@DigitalDesignDude 

 

i don't see that problem.

 

canvas project

layer 1 created

created 3 keyframe in layer 1 and assigned labels

created layer 2.

copy all frames in layer 1

right clicked at end of layer 2 timeline

clicked paste and overwirte frame

renamed layer2 frame label f5 to abc

 

 

kglad_1-1713983683443.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Thank you for trying it out @kglad !

 

It seems you have to make a frame selection that spans more than one layer in order for the bug to occur. I can't replicate the bug when I copy and paste a range of frames from only one layer. So I'll edit my reproduction steps to include that detail. Thank you for pointing that out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

i don't see that problem, either.

 

create two layers with frame labels

create two more layers

kglad_1-1713985441770.png

 

copied the all frames from the labelled frames

used paste and overwrite after selecting a frame in both empty layers

changed one of the labels in one of the pasted frames

 

kglad_0-1713985401370.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Thank you for your continued effort @kglad This is helping to narrow down the issue even more so.

I've discovered from your attempt that the pasted frames must be pasted to somewhere within the same layers that they were copied from in order for the bug to occur.

 

Should you not have the bug occur even if you follow the same minimal steps I've shown in the below brief minimal reproduction steps video then it's very likely this bug is not reproducible and is an isolated issue.

 

https://youtu.be/c8jep2Q42JE?si=6wyFOv1d54Yxym1d

 

Thank you again for your time @kglad 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

still don't see it:

 

kglad_0-1713988786078.png

 

kglad_1-1713988835428.png

 

 

kglad_2-1713988864615.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

Thanks for confirming that @kglad.  It seems to be an obscure isolated issue that very few people deal with for whatever reason.

 

If I ever come up with a convenient scripted workaround for this problem I will certainly share it here for anyone else who encounters this bug as regularly as I do. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2024 Apr 24, 2024

Copy link to clipboard

Copied

ok.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2024 Apr 27, 2024

Copy link to clipboard

Copied

I can confirm this is still happening to me on the latest animate. I think it has something to do with copy and paste also. After pasting sets of looping frames 5/6 times, going back to change the labels the field becomes blank. Just looking at the labels in the timeline is not where the problem happens. if you try to leave the field without writing in a new label, the label becomes a '?'

 

Here's how to reproduce it from a blank document: https://youtu.be/Lz2L5FZcyc8?si=PUDD7XfNvMXVYBUj

 

Easy to reproduce. copy two labels into the same layer further in the timeline, then try to edit a label name. It will clear itself, and you cant edit the text in there. you have to re-write it all. Very annoying.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 27, 2024 Apr 27, 2024

Copy link to clipboard

Copied

@BSB2018 

 

you need to give complete step-by-step instructions so others can try to reproduce the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2024 Apr 27, 2024

Copy link to clipboard

Copied

I made a youtube video showing how to do it from a blank page, but let me write it out clearly for you:

 

1) Start a new document

2) Create a new keyframe on frame 1, go to the label input in properties, enter a name (beans1)
3) Create another new keyframe at frame 10, give it a name (beans2)
4) Select frames 1-10 on the timeline, right click, copy frames

5) go to frame 15 on the same layer, paste frames

6) click on frame 15 (a copy of label beans1), click on the label name box in properties.

7) the input box will blank itself out. you can't edit the text to beans3. you'd have to re-write it. this is not the normal behavior

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Apr 27, 2024 Apr 27, 2024

Copy link to clipboard

Copied

LATEST

Just to add some historical context:

This bug first appeared in Flash CS4 and persists through CS6.

It is not present in AA 2015 to AA 2019, and was then re-introduced in AA 2020.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines