Are Layer Effects useless?

Explorer ,
Feb 28, 2020 Feb 28, 2020

Copy link to clipboard

Copied

 

   Hi, there!

 

   I've been trying to use layer effects on Animate CC 2020 with After Effects 2020 (actionscript 3 file, not html5 canvas) and they are simply not been exported. Advanced layers are checked, i tried importing both .swf and .fla files, i've tried exporting different .swf versions - and i actually have tried exporting a movie from Animate itself* and EVEN THEN layer effects are ignored. There is a message on the output panel that says that layer styles are DISABLED on .swf...


   Does anybody work with layer effects here and could help? Thanks on advance.

 

(*) - By the way, animate generates an UNCOMPRESSED .mov before sending it to the movie encoder... very time and machine consuming, that's why i'd rather export a .swf and use it on after.

TOPICS
How to , Import and export , Missing feature

Views

1.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 28, 2020 Feb 28, 2020

Copy link to clipboard

Copied

 

  There is one way we found out here: exporting an image sequence. It works, but i believe it is a workflow nightmare... 😕 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

Just more pathetic standard late-stage capitalism par for the course, brought to you by another prototypical greedy corporation.

Millions of dollars and an army of software engineers aren't enough to overcome terminal greed and apathy for one's own product and customers.

I thought I rendered a movie directly from Animate once where the blend modes showed up correctly. It must have been a fluke.

Just getting to this point where I find out that blend modes don't work (why even have the option? what is the point of all the endless software updates if basic things are broken?) has taken time and effort out of my day that I could have spent getting things done.

Thanks for nothing, Adobe. Thank God I don't have to pay for this ridiculous subscription out of my own pocket. I wouldn't have the gall to charge for these broken products.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

I'm also getting a message on my swf export...

"Layer Effects are disabled in the swf"

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

LATEST

Layer effects are disabled if you have the "Optimize for After Effects" option enabled in your publish settings. Turn it OFF to make FX appear in the SWF export.

2021-06-26 12_04_17-Window.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

Update to version 21.0.7. 


Multimedia Developer, Character Creator, and Animator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines