Crosshairs/Reticle and Export Issues

Explorer ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

I'm seeing this weird reticle thing show up on my stage:

Alyssa5CFD_0-1646970318562.png

I'm pretty sure it's the reason why my exports are cutting off. 

It's all the way out here

Alyssa5CFD_1-1646970362163.png

And this is what my export preview looks like. 

Alyssa5CFD_2-1646970387490.png

Any idea what that little mark is or what my issue is with the export?

Views

93

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Mar 18, 2022 Mar 18, 2022
Thanks to n.tilcheff for helping! Turns out the problem was that the element on the MAIN timeline was set as a movie element and not a graphic. Even though all the internal elements were graphics. 

Likes

Translate

Translate
Mentor ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

The + mark is called the Registration Point and is the 0,0 point of the local coordinate system of a symbol.

Run export from the main timeline and not from inside of the symbol.

(Adjust stage dimensions and symbols size the way you want them.)

 

You can find in-depth information about symbol registration here.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Powertools Team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

That fixes the export issue, but now none of my symbols move 😕 I unknowingly did all of my tweens and such within the clip group. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

Give that container enough frames to have the time to move on the main timeline.

If it is a Movie Clip click on it and convert it to Graphic in Properties.

This will make the internal timeline play and sync with the main timeline.

 

Working inside a container is exactly how it should be done. Good practice tells us to not animate on the main timeline, so you have not made a mistake there.

 

Is this your first time using Animate?

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Powertools Team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

I'll play around with what you suggested. I've used animate a fair amount but not recently. Thank you for your expertise!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

My main timeline is exactly 44 frames, as is the clip group. Every single element is a graphic not a movie. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

Due to insufficient information I cannot figure out exactly how your file is set up.

If you like, you can upload the FLA to google drive and send me a link in a PM to quickly fix it for you to play on the main timeline and to export fine as GIF.

 

When I saw your screen print I thought the jazzy pic looked very stylish.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Powertools Team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 18, 2022 Mar 18, 2022

Copy link to clipboard

Copied

LATEST

Thanks to n.tilcheff for helping! Turns out the problem was that the element on the MAIN timeline was set as a movie element and not a graphic. Even though all the internal elements were graphics. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines