Embedding OLE objects is unsupported. Use File->Import to import media.

Community Beginner ,
May 15, 2021 May 15, 2021

Copy link to clipboard

Copied

I'm having a strange bug while running a Jsfl script on Animate 2021 Windows 10, which import bitmap or video files in an Item, then insert them on the Timeline.

 

doc.editScene(0);
timeline.setSelectedLayers(2);
var lyr = timeline.layers[2];
lyr.locked = false;
var itemIndex = lib.findItemIndex("flvFileName.flv"); // Or Jpeg file
var theItem = lib.items[itemIndex];
//lib.addItemToDocument({ x : 0, y : 0}, theItem); // Same thing
doc.addItem({ x : 0, y : 0}, theItem);
// POPUP ERRROR (randomly)!

 

But it randomly popup a dialog box which contains :

 

Embedding OLE objects is unsupported. Use File->Import to import media.

 

I've search the origin of this random bug in 2019, without any solution and forget it. But I'm actually reworking my script for an another project and it randomly stop{4] with this annoying popup dialog box.

While searching, I discover some logs [1] in Windows which appends each time I run the Jsfl script and the popup appears.

 

Then, searching to fix the permissions following this [2], I discover that it's can be related to the Active Directory Domain I use.

 

So I've tested the Jsfl script on a "MYCOMPUTER\foo" local computer user account and the script the run without OLE random bug. What?!

 

And if I come back to a user in "MYDOMAIN\bar" AD account, then it randomly show the OLE dialog error.

So it can be the Active Directory setup which cause this bug, and it's a Samba4 one. In the Samba4 doc, it say:

 

"Samba also does not support remote manipulation of registry objects via DCOM (Distributed Component Object Model), which has not been implemented in the DCE/RPC server. This group of protocols is described in MS-COM and MS-DCOM."

 

Also, I've found a page, old page, remember Macromedia Flash! in 2004 [3] which tell us:

 

"[…] OLE related since the Macromedia site specified that dragging and dropping action was controlled through OLE, whereas copying and pasting might not."

 

So, I think I've found the origin of the bug. Is Adobe can confirm it?


I known I'm using an special config with Samba4 as AD, but Adobe is using a drag/drop controlled through OLE as in the original Macromedia code? I'll be very please if Adobe devoleppers can check an eye on this part of code and perhaps update it to not use OLE for drag and drop in a future release, or authorize in the Jsfl API to copy an Item from the library to paste it to the fl.getDocumentDOM() as a workaround (cannot find how to do that with the actual JS API)

 

I've already report a bug (ANI-4230022) and hope it be solved one day.


[1] https://honeywellprocess-community.force.com/opcsupport/s/article/How-can-I-enable-DCOM-logging-in-E...
[2] https://appuals.com/how-to-fix-the-application-specific-permission-settings-do-not-grant-local-activ...
[3] https://board.flashkit.com/board/showthread.php?599210-quot-Embeding-OLE-Objects-quot
Old related (2019):
https://community.adobe.com/t5/animate/erased-old-forum-messages/td-p/10610513

 

[post edited by moderator]

TOPICS
Error , Product issue

Views

47

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation