Exported GIF images not looping despite settings.

Community Beginner ,
Nov 30, 2017 Nov 30, 2017

Copy link to clipboard

Copied

I cannot get any gifs to loop their animation when I export from Animate CC (2018), even though I have the looping set to "forever" in the export settings. They loop in my mac's finder window, but I'm pretty sure Finder loops all gifs regardless of their settings. When I drag the files into a web browser, they only play once. Same results for both Chrome and Firefox. Why is my "forever" setting just getting ignored when it exports? How do I fix this? I have dug up some iffy websites that let me upload the gif and set it to loop forever, but the image quality and frame rate go down.

TOPICS
Import and export , Product issue

Views

19.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 16, 2018 Jan 16, 2018
Interesting workaround. So far I’ve gotten around it by turning the loop setting off and on again in the export menu before I save. For some reason, (at least for me) toggling that setting must reset something somewhere. It feels like a random pointless extra step, but so far it’s worked.

Likes

Translate

Translate
Adobe Community Professional ,
Nov 30, 2017 Nov 30, 2017

Copy link to clipboard

Copied

i don't see that using windows chrome/ff/ie.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2018 Jan 16, 2018

Copy link to clipboard

Copied

I think I've found it! Maybe...

I changed it to Type Optimized and from Perceptual to Selective and that seemed to have worked a few times already...

Anyone else?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 16, 2018 Jan 16, 2018

Copy link to clipboard

Copied

Interesting workaround. So far I’ve gotten around it by turning the loop setting off and on again in the export menu before I save. For some reason, (at least for me) toggling that setting must reset something somewhere. It feels like a random pointless extra step, but so far it’s worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

This finally worked for me as well using your method. Not sure why this is such a problem, but glad you guys gave me a workaround!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

Wow! Thanks for that workaround. It worked for me as well.

Impressive that this is still a thing. Come on, Adobe. Fix it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 28, 2018 May 28, 2018

Copy link to clipboard

Copied

Thank you so much for that - i was baffled by the non-looping too.... Toggling the looping settings fixed it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2019 Oct 26, 2019

Copy link to clipboard

Copied

This fixed it for me, too! Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

That's crazy. And who'd have thought it. Still not fixed after all this time. Not surprising.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Just wanted to let you all know that this is fixed in Animate version 21. No work around needed now, please check and let us know if you still face any issues with this.

 

Thanks!

Mohan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 21, 2021 Apr 21, 2021

Copy link to clipboard

Copied

Not fixed. I still have this bug in the latest version 21.0.4

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

Still not fixed, just downloaded version 21.0.7

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

LATEST

Sorry, it works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Thanks for sharing! Much appreciated. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines