• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

HTML5 video plays only 6 times.

Explorer ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

HI,

 

I have a couple of video in different components.  And have buttons that show and hide the components.

 

The problem is afer a coule of times turnng on and off the videos.  6 times usually , the videos stops showing.

dont know if this jas happened to anybody.

any help would be appreciated.

 

thanks

 

 

 

Views

409

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

check your developer console for errors 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

thanks kglad,  this is what i get in firefox:

Screen Shot 2024-05-24 at 6.31.57 PM.png

this is the other file that im making whie we figure out how to load the video with code.  On this file im using 25 independent video components.
let me know if you had a chance to look at the file i sent
thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

do you have chrome?  it doesn't list a bunch of extraneous messages like firefox does.

 

also, you're looking for messages that occur at the same time as the error appears.  eg, if clicking something 6 times shows the error on-stage. you'd want to flag anything that appeared in the console with the 6th click.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

this is the console wne the video doesent load:

Screen Shot 2024-05-24 at 9.43.19 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

Hi Kglad,

 

I finished building the interactive with videos loading into components. all good.

but im still having issues when sometimes videos dont run.  Please if you can take a look at this demo video with dev console open.  I dont see anything changing when the videos dont load.  also in the zip is the fla file if you want to take a look at it.

thanks

https://wetransfer.com/downloads/35594a90be73916fe628c1535402804720240526014250/b62b3d77ba73169154a1...

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

you're executing code repeatedly when you return to frames code.  that's going to cause a problem soone or latter.

 

to prevent use:

var alreadyExecuted;

if(!alreadyExecuted){

alreadyExecuted = true;

// put code here that you only want to execute once.

}

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

Not sure if i understans.  you mean when i use the

this.gotoAndPlay(4); codes for example?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

your listeners are being duplicated.

 

do you know how to use console.log()?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

no,

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

how to debug animate canvas

 

lesson 1:

https://m.youtube.com/watch?v=bG05_am-fQI

 

lesson 2:

https://m.youtube.com/watch?v=H9e9toftvdM

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

HI, THANKS FOR THE VIDEOS.

 

i now undesrtand more how to locate problems using console, and how to use console.log().

 

bue still dont understand which listerers are being duplicated, and how to stop them.

i have 2 wrnings and 1 issue:

Screen Shot 2024-05-26 at 11.23.45 AM.pngScreen Shot 2024-05-26 at 11.24.14 AM.pngScreen Shot 2024-05-26 at 11.27.50 AM.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

in one of your button listener functions put a console.log("button whatever was clicked")

 

then see how many times that executes affect returning to the frame where you're adding that listener.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

ok, i did, each time i click on button_3 i get a count.  (this button pauses the video and shows the menu esp movieclip

afetr 20 clicks , te next video didnt load, then others dis, and others didnt

 

does having the othe hide events that robably are repeated en each return an video play cause the problem?

Screen Shot 2024-05-26 at 12.17.34 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

you actually used your mouse to click that button 20 times?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

yes,  that is the back button that get you out of the video, back to the videos menu page.

that button would be used many times.

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

then that's not the issue.  do likewise for buttons that load videos.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

here i placed a console log at each button that loads video.

after clicking for video and clichoin to go back , i get an empty video

Screen Shot 2024-05-26 at 12.42.26 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

you're loading 14 different videos?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

29

1 intro,

14 in spanish

14 in english

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

i don't know then.  you'll need to continue debugging to see if you can find what triggers the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

could it be a video format?
maybe using webm?

the only warnings i still get are these:

Screen Shot 2024-05-26 at 1.25.18 PM.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

i thought the videos play fine the first time.  it's only on repeats that it fails.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

correct, all play fine,  and repeat fine, untill they dont no more...

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 26, 2024 May 26, 2024

Copy link to clipboard

Copied

also, every time i get this problem,  i try to test again from animate, but the program gets stuck in the process.  i have to force quit, reopen the file and then test.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines