• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Motion Tween Problem in Adobe Animate.

Community Beginner ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

When I create a motion tween and when I select it and use left and right arrows to relocate the movie clip, the movie clip object goes down. I have never pressed down key but it happens. Sometimes it happens when I trying to move the object with mouse too.

 

Movie clip is made by a bitmap, bitmap has resized firstly, then has been converted to movie clip.

you can see it in this video:

 

Really appreciate for anyone's helping. Have a good day.

TOPICS
Error , Other , Performance , Product issue

Views

446

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

And its pivot point moving too although not touching the pivot point.

 

Even if I press "Ctrl + Z" to undo the move, the object's position is correcting but its pivot point and the object in the first frame of the motion tween is moving . That makes this error irreversible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

i don't know why that's happening though if you can update your keyboard drivers, that might fix the problem.

 

to work around the problem, use the properties panel.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

I think that is a common problem and I've tried it with another computer with different animate version and project 3 months ago and same thing had happened too. Ctrl+z doesn't work and corrupts motion tween as well. and that problem definitely happens when you convert a bitmap to a movie clip and resize the movie clip (not the bitmap in the movie clip) and convert it to a motion tween and move it with your keyboard or mouse, but sometimes occurs when the movie clip object has the same size as its bitmap object.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

i couldn't duplicate that problem:

 

in an as3 project, i imported a bitmap, converted it to a movieclip, resized the movieclip (once with the reg point centered and another time with reg point off-center), applied a motion tween and adjusted to movieclip's position using the right arrow key and saw nothing abnormal. ie, the movieclip moved right only with no vertical motion.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

My bitmap was 16x16 px and resized the movie clip to 64x64. if you tried like that too, there is nothing to do. Maybe it's because I'm using the Turkish version of adobe animate or something :(.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

i imported a 16x16 jpg, converted to a movieclip, resized the movieclip to 64x64, applied a motion tween, applied the right arrow:

 

kglad_0-1680709199959.png

 

and saw no problem.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2023 Apr 05, 2023

Copy link to clipboard

Copied

I have created and uploaded an animate file to dropbox so you can download and try it too: 

https://www.dropbox.com/s/ngir46hu8ukcaak/animate_bug.fla?dl=0

 

I selected the last frame of the motion tween and pressed right, down, up, left arrows one after another for a few seconds like in the video. As you can see the pivot point messes up as well and Ctrl+z wouldn't fix the problem:

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 06, 2023 Apr 06, 2023

Copy link to clipboard

Copied

that wasn't an adobe error. you had multiple problems including sizing problems and more importantly inconsistent transform points.

 

here's your correctly fla.  you should be able to use your arrow keys (or mouse) to create whatever motion tween you want, https://www.kglad.com/Files/forums/animate_bug_v1.fla

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2023 Apr 07, 2023

Copy link to clipboard

Copied

Thank you for your help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2023 Apr 07, 2023

Copy link to clipboard

Copied

@SuperNova90 

 

you're welcome. is everything working the way you want in that v1 fla?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2023 Apr 07, 2023

Copy link to clipboard

Copied

Yes, I didn't have any problems.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 07, 2023 Apr 07, 2023

Copy link to clipboard

Copied

good to hear!  (and good luck with the rest of your mario project!)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2023 Apr 07, 2023

Copy link to clipboard

Copied

LATEST

Thank you! 😊😊

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines