Pixel Perfect Movement - camera and tween

Community Beginner ,
Jul 04, 2021 Jul 04, 2021

Copy link to clipboard

Copied

Animate allows the "snap to pixels" option for bitmaps which has been a huge help in the pixel-art animation I'm creating -- but once you tween them they need to be graphics so they don't snap, and the tween won't stick to integer pixel values. Additionally the camera doesn't have that snap to pixels option -- so even if my bitmaps are snapping to pixels, the whole render context can easily become offset and the benefit of the snapping is lost. For context, since I don't have interpolation settings any crisp pixel art will be interpolated and destroyed on export if it is ever at a sub-pixel position on the stage. 

 

I'd really like to stick in this environment since premiere and after effects are unwieldy for this kind of character animation and photoshop tends to really chug with the length of footage I need to create... is there any fix?

Views

83

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jul 07, 2021 Jul 07, 2021
Well, it wasn't the camera or the tweens at all, but bitmap import settings. "snap bitmaps to grid" is all fine and good but the real solution is to change the bitmaps' properties by right clicking them in the library and setting "allow smoothing" to false and changing the compression to png/lossless. I was 30 seconds away from re-animating the entire sequence in another software and I would like to thank the almighty "googling one last time while waiting in line for coffee after staying up unti...

Likes

Translate

Translate
Community Beginner ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

I'm also now seeing, when I try to manually correct the issue, that the camera actually won't allow me to trim the decimals off its position even on still frames. If I manually type "275" in as the x position, as soon as I press enter it changes to "275.65". Any ideas why this is / if there's a fix?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

LATEST

Well, it wasn't the camera or the tweens at all, but bitmap import settings. "snap bitmaps to grid" is all fine and good but the real solution is to change the bitmaps' properties by right clicking them in the library and setting "allow smoothing" to false and changing the compression to png/lossless. I was 30 seconds away from re-animating the entire sequence in another software and I would like to thank the almighty "googling one last time while waiting in line for coffee after staying up until 3am" thank you very much

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines