• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Problem with Pen tool

Community Expert ,
Jul 11, 2017 Jul 11, 2017

Copy link to clipboard

Copied

Hi. When I draw with the Pen Tool, Animate create additional anchors, how can I fix this behavior? Maybe is a bug? You can see the issue in this video: anchors - YouTube

Thanks

Marlon Ceballos.

Views

2.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Jul 17, 2017 Jul 17, 2017

A quick update: The team has verified this issue and has logged a bug for it.  Thank you for your investigation. I will update this post when I have more info.

Thanks,

Preran

Votes

Translate

Translate
Participant ,
Jul 11, 2017 Jul 11, 2017

Copy link to clipboard

Copied

I believe the problem arises when you exactly line up the two handles for the middle point. I was able to replicate the problem creating this shape in a few different ways - when the two handles intersect the shape is redrawn with extra points.

Going through the same process in Illustrator does not result in the same effect.

The solution appears to ensure that the two handles are as close as possible without intersecting, not ideal I suppose.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 11, 2017 Jul 11, 2017

Copy link to clipboard

Copied

Yes, you're right. When the control lines are aligned or they cross Animate creates additionals anchors. Seems to be an Animate bug.

Thanks a lot!

Marlon Ceballos.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 12, 2017 Jul 12, 2017

Copy link to clipboard

Copied

I can't recreate your video! I choose the pen tool, click and drag upwards. I click and drag downwards to make the left arc. I press C to switch to the Convert Anchor Point tool, and move the lower right handle up on top of the upper right handle. I press P to switch back to the Pen tool, and I click and drag downwards. No matter what, that becomes a new line.

So, two questions:

How did you switch to the Convert Anchor Point tool without the tool palette changing? It remains on the Pen tool.

What are you doing that is different to my description, that would account for me getting a new line, and you getting a second arc?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 12, 2017 Jul 12, 2017

Copy link to clipboard

Copied

Never mind, I figured it out! Holding Option down makes it change for a moment.

I can now make two arcs, but I don't get the extra handles. I'm using 16.5.1 that was uploaded on July 4th, is it possible that the problem was just fixed?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 12, 2017 Jul 12, 2017

Copy link to clipboard

Copied

I was later on able to see the problem. I can't get it to happen most times, and I'm not sure what I did differently the times the problem did show!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 12, 2017 Jul 12, 2017

Copy link to clipboard

Copied

Hi. I have the same version. Seems to be a bug of Animate.

Marlon Ceballos.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 17, 2017 Jul 17, 2017

Copy link to clipboard

Copied

Thank you for confirming. I am checking with the team to see if we have a bug logged for this one.

Thanks,

Preran

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 17, 2017 Jul 17, 2017

Copy link to clipboard

Copied

A quick update: The team has verified this issue and has logged a bug for it.  Thank you for your investigation. I will update this post when I have more info.

Thanks,

Preran

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2018 Sep 27, 2018

Copy link to clipboard

Copied

Hey there, this post is now over one year old. No improvement on the issue so far?
Maybe ToomBoom could be the answer?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2024 May 21, 2024

Copy link to clipboard

Copied

LATEST

Still happening six years later...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines