• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Some body can help me?? Is very urgent to me finnish it. I promeis don´t back to use Animate cc! :-(

Community Beginner ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

First of all... Thank you KGlad!!!!!! for your help. I appreciate it. I'm watching the videos, but to me that's "Chinese" because I'm not a development guy... and I have no idea about code, just the easy way that Animate cc offers me to do the basics. Finally yesterday I have the idea to upload it to my server (even when I can't see anything published in my browser) and the surprise was when I can see it perfectly on the internet. But the problem doesn't end here... The landing page works perfect, the menus on top, the buttons puppies... but the BIG problem now is when I go to the pages puppies... the menus on top work only for a few seconds and then they stop for no apparent reason, since on the landing page they don't... I can't understand anything. All the code is very simple and I can't see any errors... I search and search but I can't find the problem. It's desperate... I need to get it working before the puppies grow up. :(( Animate cc is great software, but I think it's a bit more "want to but can't"... I spend a lot of time and now I can't use it. P.S: I can't let you know my full domain name because the "older brothers" say that the word "-----" is not allowed to be said. 😕 ... [link removed by moderator]

Views

265

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

the first error i see is

 

_this.Bt_DB_Fotos_Videos is undefined when this code executes

 

_this.Bt_DB_Fotos_Videos.on('click', function(){
/*
Loads the URL in a new browser window.
*/
window.open('https://www.dropbox.com/sh/colyat2wcggc14l/AAAqaZ-ddxx-F2Hc-RDBBVGaa?dl=0', '_blank');
});

 

(actually, that's not the first.  the first is trying to start a sound before anything in your app is clicked.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

Ok... I´ll take off all buttons sounds of the project.  Thnks KGlad!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

button sounds are ok. you must have some other (eg, background sound) that's failing to play.

 

the bigger problem is the undefined object 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

KGlad ...twice days before, I have the same problem with the menu buttons at my landingpage and the only way to fixed it was locate the buttons up of the timeline. That was crazy!! I expended hours to try fix it and the solution come to me when I did this stupid and unsdestanble decition. 8´/

I like Animate cc but I don´t see any future at a software with this insures... it´s no serious. After this .....uck experience the Animate cc is finnish to me. Maybe with the adquisition of figma their will make the stuff better.

 

Here I let you my puppie projetc, if you have time to help me welcome, if no is ok. I will make some poster ad print for put it around my city... you know, like vintage style.  😞

 

Thks a lot for your last answerd!

 

https://www.dropbox.com/scl/fo/dfezx12s6qgnlaowh0xak/h?dl=0&rlkey=7oqopjo1g1d2a6ye40pzd7tby

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

the issue(s) you're having isn't because of a problem with the software. it's a problem with you understanding how to find and fix problems.

 

i make lots of errors when coding. in particular, i'm prone to typing fast and generating typos, but i know how to quickly find and fix those problems so i code quickly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

_this.Bt_DB_Fotos_Videos is undefined because that code is on the 1647th frame and the button doesn't exist until further down the timeline (~1664th frame)

 

 

kglad_0-1668186629484.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

Hi ...KGlad. Thank again for your considerate to offert me your help. Really I moved all this buttons that don´t work at the timeline for see if that work. Before It was at the same frame number that ussually I put the action .stop

In my ignorance of coding I thought that maybe if I gave it time to load (putting it in the timeline before reaching the stop) it would not stop working once it stopped until the user decided to continue.

My idea is remake the buttons (that don´t work) again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

code attached to a frame executes before anything on stage is updated.

 

eg, instances referenced in code need to exist when the code executes. ie, in the frame with code or before the frame with code. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

Sorry me KGlad... but my knowedge about code is less of nothing. But I discovery the problem about the buttons at doggies seccions let of work when the movie of the car-puppies stoped. If I delete this movie... all buttons work fine. The problem if that I don´t know how play this animate with out the buttons work normallity. I will try do it at the same scene... and I will let you know is that work. Anyway... I continue thinking that Animate cc must be aniquilate!!!!  (or start to study code)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

at this point, you're in the middle (or at the end) of your project and just starting to fix the problems.  that's very complicated and NOT the way any project (whether created with animate or anything else) should be done. 

 

imo, just looking at your almost 3000 frame fla is depressing.  it's overly-complicated, messy and not well-organized.  (and i did the same thing, and worse, when i started using animate/flash way back when.)

 

i suspect most of us make these beginner errors with the first platform we use for coding.  for you (and me) it is/was animate/flash.  we both started with complicated messes.

 

otoh, when i started to use unity to code and animate with c#, i was extremely well-organized because of what i'd learned with flash/animate.  same with html/css/javascript with my prefered developement tool (a text editor, sublime).  once you learn how things can quickly get complicated, you take a lextra time at the beginning to organize your layers (and use folders) and organize your library (and use folders), and organized your instance naming etc.  it's makes things much easier later in the project when you barely (or don't even) remember what you did at the beginning.

 

anyway, you're at the middel or end of your first attempt at coding and are experiencing all the problems expected of a first-timer. EXCEPT, there's one basic thing you failed to grasp:

 

the better work-flow (with any tool), is to create some visible stuff and/or code (but not a lot of visible stuff and not a lot of code), and then test.  if there's a problem, fix it before proceeding.  only when that first part is working correctly, would you add more stuff on stage and/or code.  and you continue in this manner until the project is complete. 

 

ie, it's a lot easier and faster to debug a 5 frame project with 20 lines of code in one of those 5 frames (even when this limited debugging must be done over and over hundreds of times) than it is to debug a 3000 frame project with scores of lines of code spread all over the main and secondary timelines.

 

and that's where you are now, stuck with 3000 frames and code spread all over the place with things not working the way you want.

 

at this point, unless you're very close to finished it might be preferrable, to redo your project.  ie, create a new fla.  copy and paste some stuff from the current problematic one to the new one.  fix whatever's not working and once that's complete, copy and paste more stuff from the current problematic one to the new one.  continue until everything is copied and working.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

Thank you KGlad for everything, the help you have given me and for the time you have used. It is true that I am not a user of animate, nor was I a Flash user and before that I was the Director of Macromedia, which is the grandfather of Animate until Adobe bought it to later release it as Flash. But the truth is that although this also had its own thing, but it was not even remotely close to Animate cc, which in my opinion has things that are already escaping all logic. Of course my lack of knowledge in coding is a big enough limit to tackle a project that is too complicated... but this is not it. It's the simplest thing you can do... buttons that come and go to labels, others that make calls to the www and a couple of movies. When I decided to do it, I didn't think it would get complicated with things like for example buttons that don't work (without knowing why) but when placing them in a higher timelime position they suddenly work... this if there was something in between timeline nothing relevant that could be the explanation of why they did not work before. Now I've solved the problem with the buttons in the puppies section, simply taking the movie to the main scene suddenly works perfectly again (now the only thing is that instead of 3800 frames I have 8500, but hey... it works that is what I want to be able to start putting up the posters in search of adopters of the puppies (puppies when I started doing this project with Animate cc... we'll see how they will be when I finish it) Why now (I did the test when I passed the movie of the first puppy to the main scene and it worked well, also the second... and once I verified that everything ran perfectly and the buttons worked correctly... when I finished and published it, again the screen was blank ! that they do not do the same with Figma. Thanks again for your help and time spent.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

And let's see if they remove the filter (de los huevos) because you can hardly write anything in this community without being censored. 😞

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

LATEST

you're welcome.

 

p.s. when you see a blank page during testing, it's because of a coding error.  open the developer console to find the location of the error.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines