• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Some symbols have glitched tweens or can sometimes disappear after exporting

Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Hey, this is my first time posting something to the Adobe forum, so hopefully I'm speaking in the right place.

So, I'm playing a file that I had animated over the past month. Roughly 70-75 seconds long, uses just under 29 MB, and runs on ActionScript 3.0. When I'm playing a file inside, everything seems to be going normal except for some output lag probably caused by the density of symbols in some areas. That's not really my problem here. The problem I'm having here is that sometimes, the tweens of symbols (primarily nested symbols) tend to glitch and show themselves being extremely buggy. Not all tweens do this, but even if a tween looks completely normal in the file, it will tend to do actions post-export that should not be possible.

An example of this I will provide is a symbol that moves down through a Classic Ease. Some symbols nested within this symbol will pulse colour at specific intervals, but as a separate symbol they do not move other than the Color Effects being tweened (it just moves with the symbol it is nested inside of). Looks normal in the file, but after exporting, these parts of the tween will move in the opposite direction of what is displayed in the file, before jumping back to it's proper end position at the end of the tween. Some other symbols may also overshoot their designated tweens post-export, going too far in the tweening motion before jumping to it's intended spot at the last frame.

And then, the biggest exporting issue I'm having right now is that some symbols masked in the main file (aka. not nested inside any other symbols) will not show at all. What looks like a proper motion inside the file becomes mostly a black screen in areas where it is masked, but all symbols/objects that aren't masked still show. One reason I think this may occur is the fact that some layers inside the mask are locked to the camera tweens (I used the camera tool as well), and others aren't. But then again, if this really made such a massive issue, then shouldn't Adobe Animate prohibit users from individually changing whether or not masked layers follow the camera (as in, if the mask parent is locked to the camera, all masked layers must be as well, and vice versa, regardless of what layer changes this status)?

All symbols inside of my file are Graphics. Not sure if that may have anything to do with any issues, but if you believe it does, let me know! And if showing the exported files compared to the parent files to show what should show up would help, I can provide them. Same will go for any other questions you may have.

Thanks!

TOPICS
ActionScript , Import and export

Views

471

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Guru , Oct 24, 2023 Oct 24, 2023

Hi mate,

I had a look at your FLA which is quite complex and will take a lot of time to try to trouble-shoot, which, unfortunately I don't have.

I saw the issues that you face, and suspect that a combination of factors leads to the glitches.

There are multiple bugs with masks in Animate, introduced with the so-called Advanced Layers, which were never addressed. And you heavily rely on all those unreliable new features: the camera, the frame effects, etc.

 

My suggestion is to try and render this as a

...

Votes

Translate

Translate
Community Expert , Oct 25, 2023 Oct 25, 2023

Ok, I did some tests and it's clear we're dealing with two bugs here:

 

#1 Involves frame filters: At 0:12 - 0:19 a tint color effect is making "Symbol 18" tween incorrectly. No other frame effect seems to be bugging out as far as I can tell.

Mario_CR_2-1698258284534.png

 

Workaround: Remove the effect on the frame and re-apply it at object level on the graphic symbol instead.

Mario_CR_3-1698258515021.png

 

#2 Involves pin to camera: At 0:33 - 0:36 and 0:41 - 0:44 you have a mask layer with several masked layers underneath, with only some of them pin

...

Votes

Translate

Translate
Community Expert ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Hi, could you provide the file to pinpoint what the issue is? You can do so using a file sharing service like google drive, onedrive, wetransfer etc.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

I'm trying to link the .fla so you can access it, but every time I try to post it with that file, I get this message:Screenshot 2023-10-24 at 2.20.42 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

It's not possible to upload these files in the forums, please use a file sharing service like I mentioned.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Sorry about that. I read the file sharing stuff but I didn't bat much of an eye because I think I saw others posting separate files like that before? Might've been wrong then.
See if this works. https://drive.google.com/drive/u/0/folders/1I8d1XtU9qIQKXxrK0iVpHVdR6S75H-oB Both the .fla and the exported file should be in here. If so, main issues occur at 0:12 - 0:19 for glitched tweening (but there's other examples of this scattered around I think), and then 0:33 - 0:36 as well as 0:41 - 0:44 for the broken masking.
Any other questions, let me know, and I'll try to address them.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

I don't have permissions, could you make the file public to download?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Change the sharing option to "anyone with the link", so that people on the forum can see your files without the need to ask for permission.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

How do I do this? I tried following the guidelines mentioned on the web, but I cannot find any of my Adobe Animate files on my profile. And I don't see anything where I can change the settings inside of Adobe Animate itself, right?
Sorry if I am just making myself sound confused, as I mentioned I've never shared an .fla file specifically with anyone.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Nevermind, ignore this. I think I'm figuring it out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Or idk anymore...?? I saved the file to a CC Library which I think you're supposed to do, but I don't know how to make the file publicly accessible to everyone from there. The Share tab forces me to select specific users.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

In Google Drive, click on the sharing icon:

ntilcheff_0-1698188053766.png

Then choose "Anyone with the link"

ntilcheff_1-1698188086071.png

Test the link in an 'incognito' window. Then you will know if you can see the file when you're not logged in as yourself.

You may need to post the link again here.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Oh.
My.
God.
I legitimately thought we were talking about the Adobe Animate files being privated somehow. Turns out, I forgot to make the Google Drive folder public indeed.
I'm so sorry for all the confusion, because turns out I did, in fact, confuse myself. Let's try this again. https://drive.google.com/drive/folders/1I8d1XtU9qIQKXxrK0iVpHVdR6S75H-oB?usp=sharing

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Hi mate,

I had a look at your FLA which is quite complex and will take a lot of time to try to trouble-shoot, which, unfortunately I don't have.

I saw the issues that you face, and suspect that a combination of factors leads to the glitches.

There are multiple bugs with masks in Animate, introduced with the so-called Advanced Layers, which were never addressed. And you heavily rely on all those unreliable new features: the camera, the frame effects, etc.

 

My suggestion is to try and render this as a PNG sequence. It uses a different export method and is likely going to work.

If you have not done this before, I have described the process in detail here:

https://community.adobe.com/t5/animate-discussions/export-issue-stops-mid-export/td-p/10424361

 

As a test you can try to export only the glitchy sections first to see if that will give you the desired results.

 

Hope this will be helpful!

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

ps. In fact I did a test with the masked section and it exports fine:ezgif.com-resize.gif

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Just wanting to check before I think too far into this suggested solution (and yeah... the file was a bit complex. I think me not providing enough indication for what does what in most areas didn't exactly help matters), but I did notice the section that you had exported again showed a different font from what was in the file (not sure if this is only because the text shown uses the "Platform Eight" font, which isn't automatically downloaded into Adobe). Is this something that will happen if I export a PNG sequence instead of a full animation?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

That is because I don't have your fonts installed here.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Alright, just checking. I'll try out your solution and see how it goes.
Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Also, to check, when you say to export the full animation as a PNG sequence, are you referring to the "Animated GIF" option? Because if not, what do you do here? I click on the "Export" tab from the File menu and these are the options I'm left with:

Screenshot 2023-10-24 at 8.14.07 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Export > Export Movie... -- Choose PNG Sequence, 24-bit.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Hey again.
So, I'm trying out your PNG sequence method of export, but I've run into a problem trying to edit it back together.
On that post you had mentioned earlier, you have to click on an option named "Modify" and then "Interpret Footage". However, having followed your steps mentioned earlier in the post, it appears that the first image is unable to be modified; the Modify tab is grey in indication of being unusable for the media.
Is there a reason this might be? Or might I have done something wrong?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Maybe you did not import the images as an Image Sequence?

If you have Premiere related questions you may as well ask them in the Premiere forums, where there will be much more experienced users who can guide you.

 

Making a video out of an image sequence is a very simple task and can be done in any video editing program, After Effects, or even in Adobe Media Encoder.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Power Tools team - extensions for character animation

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

LATEST

Yeah, I realize what I did wrong now.
I was able to resolve the issue. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

Ok, I did some tests and it's clear we're dealing with two bugs here:

 

#1 Involves frame filters: At 0:12 - 0:19 a tint color effect is making "Symbol 18" tween incorrectly. No other frame effect seems to be bugging out as far as I can tell.

Mario_CR_2-1698258284534.png

 

Workaround: Remove the effect on the frame and re-apply it at object level on the graphic symbol instead.

Mario_CR_3-1698258515021.png

 

#2 Involves pin to camera: At 0:33 - 0:36 and 0:41 - 0:44 you have a mask layer with several masked layers underneath, with only some of them pinned to the camera. On the timeline it looks fine but on the SWF preview the unpinned masked layers are thrown off a corner outside the stage which is why they're not rendered.

Workaround: Pin all the masked layers to the camera; once you click the pin to camera button you'll see how the layers become misplaced, adjust them manually and move them to the center of the stage, after doing so the layers should appear on the SWF properly and hence on the exported video as well.

 

Mario_CR_1-1698258041642.png

 

I'll make a bug report to the dev team about this and hopefully they can fix these in the future.

 

 

Here's the corrected file. Let me know if it works for you: https://drive.google.com/file/d/1OO_F8Bla-b3x5ltLLgZY7zXuSWYhHefp/view?usp=drive_link

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

Just tested this out, and it's working! Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines