Symbol does not follow its path on main timeline

Explorer ,
Aug 08, 2021 Aug 08, 2021

Copy link to clipboard

Copied

I planned to make HTML animation and to control interactivelly the symbol movements by EaselJS. I made a fews symbols with their own path and symbol really follows them and oriented as I expected during editing. But when I added a layer and dragged these symbols in layers on the scene they does not follow their own path but moved to last position of the symbol by following the shortest distance (a line) and in same time slowly rotated to match symbol's orientation for last frame!

I tried few days to figure out why it doesn't works as I was able last week to make similar animation (240frames) without hassle. Is it problem why timeline is 1440 frames long? Any ideas? Thanks.

Views

54

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 09, 2021 Aug 09, 2021
around 16,000 frames you can expect problems, not 1,440. you have some other problem and the way you moved the tweened frames sounds problematic.  you're less likely to have trouble if you copy the frames and layers you want and then paste them, and even less likely to have problems if you convert the layers/frames into a movieclip and move that movieclip to another timeline/layer/frame.

Likes

Translate

Translate
Adobe Community Professional ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

around 16,000 frames you can expect problems, not 1,440.

 

you have some other problem and the way you moved the tweened frames sounds problematic.  you're less likely to have trouble if you copy the frames and layers you want and then paste them, and even less likely to have problems if you convert the layers/frames into a movieclip and move that movieclip to another timeline/layer/frame.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Hello... I deleted that part and made it more carefully... then it worked as I expected. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

LATEST

you're welcome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines