• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Symbols shake when exporting

Community Beginner ,
Oct 12, 2023 Oct 12, 2023

Copy link to clipboard

Copied

So basically everytime i export my animation, even though in the app it looks fine, when i export it every symbol i used the frame picker one glitches like that, the eyes used to do the same but i used another (bad) technique to fix it, it wouldnt be a problem if the other technique wasnt so bad (making a copy of the symbol everytime i wanted to change it), since it takes too much time and space to do.
Here is the file on animate and both the glitched exports.

Views

222

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 16, 2023 Oct 16, 2023

Thank you, looks like the problem is that you still have Movie Clips inside the symbol "Cartola Mouth". These need to be removed or converted to Graphics also:

 

Mario_CR_0-1697500204461.png

 

Here's a corrected version: https://we.tl/t-1Zgy6gGbGd

 

Votes

Translate

Translate
Community Expert ,
Oct 12, 2023 Oct 12, 2023

Copy link to clipboard

Copied

Hi, double check that your symbols are Graphics instead of MovieClips so you can control the frame looping. You can change this from the properties panel.

Mario_CR_0-1697135592716.png

 

Once your symbols are graphics go to the Looping section and change the frame looping to Single Frame. If you already have keyframes on the timeline you'll have to go back and do this for every keyframe.

Mario_CR_1-1697135639386.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

Yeah, i did do this, but for some reason it just doesnt want to work when i export it, i will try to double check it, thanks for the help anyway!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

uhm... so i double-checked and even made another animation and sadly the bug still continues, would love to know what that is! thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

If it's possible, share the file with a google drive link and I can give it a look.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Thank you, looks like the problem is that you still have Movie Clips inside the symbol "Cartola Mouth". These need to be removed or converted to Graphics also:

 

Mario_CR_0-1697500204461.png

 

Here's a corrected version: https://we.tl/t-1Zgy6gGbGd

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

wait, really? but wouldnt that make the mouths not bounce when theyre used? since if you see inside them, there will be 2 keyframes there, unless thats an outdated version, but i dont really care anymore, i just want that fixed!!! thank you so much!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Yes but they just loop between those 2 keys endlessly, hence the shaking. Like I mentioned earlier, you can't control the looping with Movie Clips. As for the bouncing, I would add the bounce outside the mouth, not inside.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

LATEST

its because i plan on doing voice clips for the animation, and since  i dont want it to be too robotic i wanted the mouths to bounce when it changes, but right now im trying to animate a little to train a bit, thanks again!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines