Timeline rescaling

Explorer ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

I am composing some simple animations. In order to keep the timeline manageable, I am editing 30 second clips at 15fps which means my animation contains 450 frames. When all of the timings are perfected, I then select the entirity of the timeline, which can feature up to 20 layers or so, and then stretch to 900 frames (when the marker shows that you have exactly doubled the length of the timeline) and then modify the file to run at the 30fps the client requires. I don't know why, but this used to work just fine. Now, when I do this, all of the timings in relation to each other are, in many cases, way off! Have been using the same version for every project I've worked on (21.0.9 running on Mojave 10.14.6) but this has only just started happening. At my wits' end.

TOPICS
Timeline

Views

111

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

Hi, expanding frames requires that every layer in the selection span has enough frames to cover the selection, if they don't, they won't scale properly. More about it here: https://community.adobe.com/t5/animate-discussions/expanding-frames-without-loosing-synchronization/...

 

If you want to modify the entirety of the timeline though, why not change it using Scale Spans? It proportionally scales the frames with the FPS, no need to do it manually.

Mario_CR_0-1647883557812.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

You shouldn't need to select anything in the timeline in order to change the frame rate. Instead you look in Properties, Document Settings (click on an empty part of the stage for that to appear), then check the Scale Spans box, and change the FPS from 15 to 30.

Hopefully you have been trying to change the frame rate without having that box selected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

That would double the playback speed. The timeline needs to be stretched to double the length to match the doubling of the frame rate and keep the animation length at 30 seconds. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

The scale spans option does the doubling of the timeline length for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

LATEST

Sorry - I misread. I get you now. I shall try that. Many thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines