• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Troubleshoot issue with importing Photoshop file to Animate while maintaining transparency on layers

Participant ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

I have tried every possible idea to get the files to import while maintaining transparency. It always slaps a black background on them even though the layers have transparency. We imported as a single bitmap image and that worked, but I want my students to be able to have their characters go behind objects, etc without dealing with complexities of masking layers. I have reset all settings to default as it's only happening to two of my students, and nothing changed. I've cycled through all the various clickable options from the import menu and nothing changes. Please help me for the sake of my sannity 😆. Thank you in advance. 

Link to the photoshop and animate file. 

TOPICS
Error , How to , Import and export , Other , Performance , Product issue , Timeline

Views

183

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 07, 2024 Feb 07, 2024

On the import window I would recommend to do the conversion from the "basic" panel.

Click on "Hide Advanced Options" at the bottom

Mario_CR_0-1707334640159.png

 

then check "Mantain editable paths and effects" and finally click on Import.

Mario_CR_1-1707334676977.png

 

Perhaps you're thinking what's the difference from doing it from the advanced panel? The difference is that in the advanced panel you have to highlight every layer for changes to take effect, the "Select all Layers" option is deceiving in the sense that it only selects the layers that

...

Votes

Translate

Translate
Community Expert ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

are you selecting this option:

 

kglad_0-1707317321965.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

Yes, that way students can animate in front or behind the layers they created. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

i don't see a problem using that setting.

 

is the transparency layer (s) converted to movieclips?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

On the import window I would recommend to do the conversion from the "basic" panel.

Click on "Hide Advanced Options" at the bottom

Mario_CR_0-1707334640159.png

 

then check "Mantain editable paths and effects" and finally click on Import.

Mario_CR_1-1707334676977.png

 

Perhaps you're thinking what's the difference from doing it from the advanced panel? The difference is that in the advanced panel you have to highlight every layer for changes to take effect, the "Select all Layers" option is deceiving in the sense that it only selects the layers that will be imported, but doesn't actually apply the chosen settings to all layers, and so most of them are still being imported with the default "flattened bitmap" setting:

Mario_CR_3-1707335927160.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

Thank you for the feedback. I will test this out tomorrow. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

LATEST

This worked! Thanks so much for the added detail that select all doesn't apply the settings to all the layers "selected"... which is weird to me 😄. Thanks again. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines