Vector graphics quality when exporting to MP4

New Here ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

Hi All

I've got some issues when exporting my animation into MP4.

I'm using vectors graphics and they appear ok in my workspace but when exporting the outlines are all choppy.

I tried to increase my canvas size and tweak the settings but nothing seems to work. The only option would be to convert the symbols into bitmap but I would like to avoid this if possible.

I'm running out of ideas and hope someone could help me solve this problem

 

Thanks a lot !

Views

70

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Mar 31, 2022 Mar 31, 2022
Thanks a lot for the replies!!I actually I solve the problem by increasing the size in illustrator first and then importing again into animate. When I increase the size in animate first it doesn't work for some reason ... Now the quality is great.I'm a newby with this program and I've been learning stuff everyday Thanks again

Likes

Translate

Translate
Adobe Community Professional ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

 export of animate as a .mov first then take it into media encoder an expert MP4 should look better.


Multimedia Developer, Character Creator, and Animator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

What is the stage/document size (width & height) and what size are you exporting to? I've never seen this personally. Are you using the new advanced rigging asset warp tool by anychance? I ask because by default it converts your vector art to bitmap which could cause problems.


Animator and content creator for Animate CC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

Thanks a lot for the replies!!

I actually I solve the problem by increasing the size in illustrator first and then importing again into animate. When I increase the size in animate first it doesn't work for some reason ...

 

Now the quality is great.

I'm a newby with this program and I've been learning stuff everyday

 

Thanks again

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

LATEST

I'm coming to the party too late to help, but here is an explanation, if someone comes across the thread in the future:

 

This problem (shapes not rendering well is Flash Player) occurs when resolution is too low at raw shape level.

That is why increasing the size of the symbols in Animate did not help.

It should be done either on the inside of the symbol to the raw vector shape, or after scaling up the symbols the matrices have to be reset with Zero Transform.

 

In this case with imported artwork, obviously scaling up within Illustrator achieved the same result - increasing the pixel dimensions of the raw vectors.

 

Nick - Character Designer and Animator, Flash user since 1998
Member of the Flanimate Powertools Team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines