Highlighted

Adding Camera to Projects Causes Program to Crash when Attempting to Export or Publish

New Here ,
Jun 15, 2020

Copy link to clipboard

Copied

I just finished a short, 12-second practice animation on Animate CC. When I  finished, I added the integrated camera, and I tried to publish and export my animation. I discovered that when I added either the integrated camera or an external actionscript 3.0 camera that the program crashed whenever I tried to export or publish it. When I removed the camera from the animation, I was able to export and publish it without a problem.

I thought it could be a problem with too many vectors or something like that. So I experimented with a new file and tried exporting a very simple animation. Again without the camera, it worked fine, but when I added the camera and tried to export and publish the animation, the program crashed. I am not sure what the problem is and some assistance would be greatly appreciated. 

 

I am using the latest version of Animate CC.

My animation is a total of 270 frames with about 30 layers. 

The simpler animation was 24 frames with 2 layers. 

I hope I provided enough information. Feel free to ask questions if I didn't cover something. 

 

TOPICS
ActionScript, Code, Error, Import and export, Product issue, Publish package

Views

42

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adding Camera to Projects Causes Program to Crash when Attempting to Export or Publish

New Here ,
Jun 15, 2020

Copy link to clipboard

Copied

I just finished a short, 12-second practice animation on Animate CC. When I  finished, I added the integrated camera, and I tried to publish and export my animation. I discovered that when I added either the integrated camera or an external actionscript 3.0 camera that the program crashed whenever I tried to export or publish it. When I removed the camera from the animation, I was able to export and publish it without a problem.

I thought it could be a problem with too many vectors or something like that. So I experimented with a new file and tried exporting a very simple animation. Again without the camera, it worked fine, but when I added the camera and tried to export and publish the animation, the program crashed. I am not sure what the problem is and some assistance would be greatly appreciated. 

 

I am using the latest version of Animate CC.

My animation is a total of 270 frames with about 30 layers. 

The simpler animation was 24 frames with 2 layers. 

I hope I provided enough information. Feel free to ask questions if I didn't cover something. 

 

TOPICS
ActionScript, Code, Error, Import and export, Product issue, Publish package

Views

43

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 15, 2020 0

Have something to add?

Join the conversation