Highlighted

air for ios, upload .ipa version

Explorer ,
Feb 15, 2019

Copy link to clipboard

Copied

I am trying to upload an .ipa to the Apple store; when I finally was able to upload the file with no error given by xcode, I got a message from Apple saying that I was missing an 'asset catalog'. According to what I have seen it may be that I was missing some icons (though I added the icons that xcode said I was missing, but I didn't  add all of them and just assumed that I only needed those that xcode told me I was missing); I can not tell for sure that was the problem but I am trying to upload again with the missing icons, but whenever I try to upload, in the xcode summary there always appears the same version number. No matter what I place in the version field on the air for ios box, there is always the same version number and it tells me that there is an error because I have already uploaded a file with that version number. The summary appears with version 0.9.0, I place 0.9.8 in the animate setup box, build the ipa, and when I try to upload it it appears in code with version 0.9.0. How do I change the version so I can upload another test, to verify the asset catalog thing?

tnx

edit: the previous build had 0.9 in the version field, I have tried 0.9.8 and 0.98; it still appears as 0.9.0 in xcode

Adobe Community Professional
Correct answer by kglad | Adobe Community Professional

check your descriptor xml and update that to the correct version number.

TOPICS
Discussions

Views

142

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

air for ios, upload .ipa version

Explorer ,
Feb 15, 2019

Copy link to clipboard

Copied

I am trying to upload an .ipa to the Apple store; when I finally was able to upload the file with no error given by xcode, I got a message from Apple saying that I was missing an 'asset catalog'. According to what I have seen it may be that I was missing some icons (though I added the icons that xcode said I was missing, but I didn't  add all of them and just assumed that I only needed those that xcode told me I was missing); I can not tell for sure that was the problem but I am trying to upload again with the missing icons, but whenever I try to upload, in the xcode summary there always appears the same version number. No matter what I place in the version field on the air for ios box, there is always the same version number and it tells me that there is an error because I have already uploaded a file with that version number. The summary appears with version 0.9.0, I place 0.9.8 in the animate setup box, build the ipa, and when I try to upload it it appears in code with version 0.9.0. How do I change the version so I can upload another test, to verify the asset catalog thing?

tnx

edit: the previous build had 0.9 in the version field, I have tried 0.9.8 and 0.98; it still appears as 0.9.0 in xcode

Adobe Community Professional
Correct answer by kglad | Adobe Community Professional

check your descriptor xml and update that to the correct version number.

TOPICS
Discussions

Views

143

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 15, 2019 0
Adobe Community Professional ,
Feb 16, 2019

Copy link to clipboard

Copied

check your descriptor xml and update that to the correct version number.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 16, 2019 1